SAFIR® training session Tutorial — 06/2018

SAFIR® training session — level 1
Johns Hopkins University, Baltimore

Example: 2D thermal analysis of a beam
“Reinforced concrete section heated on 3 sides”

T. Gernay & J.M. Franssen
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1. General description
This example deals with a 2D thermal analysis of a reinforced concrete section.

General data:
- Section 30 cm x 30 cm in concrete
- 4 steel reinforcement bars of 20 mm diameter and with 30 mm axis cover
- Material model from Eurocode 2 part 1-2
- Exposed to ISO fire on 3 sides
- In contact with atmosphere at 20°C on the fourth side

The section file will be used for a subsequent 3D structural analysis. Therefore, it will also
include a torsional analysis.

2. Create a project in 2D for Thermal Analysis

From the pull down menu select:
Data -> Problem type -> SAFIR2016 -> Safir_Thermal_2d

ﬁ GiD x64 Project UNNAMED (SAFIR2016\Safir_Thermal_2d)
Files View Geometry Utilities Data Mesh Calculate Cross-Section Help

O @ G | L '_:}_.‘6—}:— Problem type ansys35 4 g I @ ? | ﬂ
Y e Conditions Caltep [
s Materials Examples »

- M [E problem data Fluent

- d OpenFoam

a @ SAFIR2016 Safir_Structural 2d
. = X SAP2000 Safir_Structural_3d
() - Toanaform. v Safir_Thermal_2d
/ ‘E‘ Internet rn“r‘ieve S e
e & Safir_Thermal_tsh

Load...
\ X @ Unload ‘

- Debugger...

To save the project select (or use icons on the left):
Files->Save or or [Ctrl + 5]

Enter a file name, e.g.: RC30x30

GID creates a directory with the name RC30x30.gid

GID creates a number of system files in this directory.

When you start the SAFIR calculation the Safir . IN, .OUT and .TEM files will be created
in this directory.

Note: the project’s name cannot contain spaces or special characters. Regarding the names
of the files, SAFIR is not case sensitive.
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3. Create the geometry in the xy-plane

3.1. The concrete section

From the left bar menu, select: Create object -> rectangle

68 GiD x64 Project: RC30x30 (SAFIR2016\Safir_Thermal_2d)

Files View Geometry Utilities Data Mesh Calculaste Cross-Section About Problem Type Help
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[Saved OK. Leaving
Enter name of the project

Follow the instructions in the command box: Enter first corner point
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Zoom on the command box:

Creating a rectangle in the XY plane
Enter first corner point

Command: |-0.15-0.19
Loom: 0.601x

Press « Enter »

->-0.13-0.15
Enter second corner point

Command: [0.150.15
Loom: 0.601x

Press « Enter »

You can Adjust the zoom to center the section on the screen. GiD displays this section:
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Zoome 1x Nodes: 0, Elements: 0 Loyers 1 (10859, 43138, 0)

Note: the blue lines represent the contour of the section, while the pink lines represent the
surfaces delimited by the blue lines. For instance, blue lines are used to assign thermal
boundary conditions to the contour of a cross-section, while the pink surfaces are used to
assign thermal properties to an area of the cross-section.
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3.2. The rebars

Four reinforcement bars have to be introduced in the section.

First, delete the concrete surface (in pink). From the left bar menu: Delete -> surface
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Select the surface and press Esc to validate.

Then, from the left bar menu, select: Create object -> circle
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Following the instructions in the command box, introduce the coordinates of the center of
the first rebar.

Creating a circle given center,normal and radius
Enter a center for the circle

Command: |-0.12-0.12]

Press Enter. This window appears in GiD. Select Ok.

=

D,

Enter a normal for the circle

(® Positive 7

() Positive ¥

i) Positive X

() Coords: 0.0 0.0 1.0

(8] 4 i In screen Cancel

Specify the radius of the first rebar.

Enter a normal for the circle
Enter a radius for the circle

Command: |D.D'I|

Press Enter. This window appears in GiD.

Then repeat 3 times this procedure in order to create the 3 other rebars with the following

coordinates for the center of the circles:
(-0.12 0.12)
( 0.12 -0.12)
( 0.12 0.12)
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At the end, you should see this in GiD:

O O

O O

Now, we need to create the concrete surface that contains the 4 holes. From the left bar
menu, select: Create NURBS surface.

Create NURBS surface]
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Then, select all the lines that define the contour of the concrete area (including the rebars
contour). Press the Esc key to validate. GiD displays the surface that includes the holes.
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4. Assign the thermal boundary conditions

In GiD, from the pull down menu select:
Data->Conditions

GiD xB4 Project: IPE300_ex (SAFIR2016\Safir_Ther
Files  View Geometry Utilities Data Mesh Calculate

@ | "%@:@%‘1—} Problem type  * P

Conditions R

Bl

Matenals

EE Problem data

o | k]e G
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This window appears in GiD:

Conditions n
a |,

|Temperature v‘ K2 @
Temperature Curve|F0

Entities Draw Unassign

Close

Select the " button (“Line”). On the first pull down list, select: Frontier constraints

Different time-temperature curves are predefined. Select FISO for the 1SO 834 fire curve.

Conditions n Conditions n
@’ 3 S - o »
. |Selecting points, lines, surfaces, volumes, layers or groups onl Front shrain - ) D
Frontier 4conditions belonging to that level are displayed rontier constraints k? @ i A? @
Temperature curve FISO v v Temperature curve, ¥ FISO
FIL!x constraints FISO0
Void constraints ASTME119
Temperature
HYDROCARB
F1000THPS
F20
F100
USER
Assign it Draw Hr=cr Assign Entities Draw Unassign ‘ ‘ Assign Entities Draw Unassign
Close

Close Close

Click on the Assign button and assign it to the section as shown below.
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iE\DKSﬂ Project: RC30x30 (SAFIR2016\Safir_Thermal_2d)
Files View Geometry Utilities Data Mesh Calculate Cross-Section About Problem Type Help
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Press [Esc] or click on Finish to confirm

Then select F20 as temperature curve and assign it to the upper side of the section.

¢ Conditions ﬁ
2
Frantier constraints - n2? @
Temperature curve F20 —
‘ Agzign Entities Draw Unazzign
LCloze

Select DRAW->Colors in the Conditions dialog box to display the frontier constraints
Press [Esc] or click on Finish to leave this view mode.
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5. Assign a torsion constraint (for the torsional analysis)

The torsion constraint needs to be applied on a node that is on an axis of symmetry of the
section. To create such a node, from the pull down menu select:
Geometry -> Edit -> Divide -> Lines -> Num divisions

GiD x64 Project: RC30x30 (SAFIR2016\Safir_Thermal_2d)
Files View Geometry Utilities Data Mesh Calculate Cross-Section About Problem Type Help
© @ Q  Vewgeomery B RDE Loyed RE-IRC A AL
‘;@) [ ] Create 4
® |Z & Delete »
o Edit Move point h
" Divide ", Lines Num divisions
'QW’ @ Join » .:.7'. Polylines Near point
Q | Lines operations » | Surfaces 4 Parameter
H= Swap arc ® ¢ »|  Relative Length
.’. Polyline » Length I
: % SurfMesh —
._\\' % Rebuild surface by boundary —
1 Edit NURBS >
N Convert to NURBS >
] ﬂ Simplify NURBS »
L Hole NURBS surface
‘{" 1 H
} I t Collapse »
mi.'-?’ Uncollapse »

Enter number of divisions: 2. Select the line at the top of the section. Validate with Esc.

GiD 64 Project; RE0:30 (SAFIR2016\Safir_Thermal_2d) -
Files View Geometry Utiities Data Mesh Calculaste Cross-Section About Problem Type Help
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[added 1 new lines to the selection. Enter m es. (ESC to leave)
Removed 1 new lines from the selection. Enter more lines. (ESC to leave)

D Hw

Then, from the pull down menu select:
Data->Conditions

Select the —°_ button
On the pull down list: Torsion constraints
Tick the box Constraint (only in GiD problem types versions prior to 1.4)
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Conditions n
2
[ Constraint:
Assign Entities Draw Unassign |
Close

Select the node on the axis of symmetry and validate with Finish.

& Gio s Praject: RC30x30 (SAFIR2016\Safir_Thermal_2d)

Files View Geometry Utilities

Data Mesh Calculate Cross-Section

COB|RRREE BRI PD b=
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Finish

Press Finish' to end selection
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6. Assign the materials

From the pull down menu select:
Data->Materials
Select STEEL from the dialog box pull down list
The Thermal tab is active.
Then select:
STEELEC2EN as Material Type

A Convection Coeff hot of 25

A Convection Coeff cold of 4

A Relative Emission of 0.7

Materials n
STEEL v‘@ OCR = e @

Thermal | Mechanical |

MaterialType STEELEC2EN ~
Convection Coeff hot|25
Convection Coeff cold |4

Relative Emission|0.7

Assign Draw Unassign Exchange

Close

Then select the Mechanical tab. Input:
A Young modulus of 210 000 MPa
A Poison ratio of 0.3
A Yield strength of 500 MPa

Materials n

Thermal Mechanical |

E-Modulus (Young)|2.1e11
Poisson ratio|0.3
Yield strength (N/m*2) |5.0k8

STEEL O K= e @

T

Assign Draw Unassign Exchange

Close

Click on Assign-> Surfaces and assign it to the steel rebars surfaces.

Press [Esc] or Finish to confirm.
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Then, select CONCRETE from the dialog box pull down list. The Thermal tab is active.
Select:

SILCON_ETC as Material Type

Modify the thermal properties of the material if needed. Modify the mechanical properties
if needed in the Mechanical tab. Then assign the material to the concrete surface.

Materials n Materials n

TR 100K 0| oo JeloiKil

Thermal | Mechanical |

Thermal Mechanical ‘

MaterialType SILCONETC ~ = Poisson ratio|0.2]
Specific mass| 2400, Compressive stengh (fc)| +3.0e7

Moisture content|48 Tension strength (fc)| + 1.0e6
Convection Coeff hot|25
Convection Coeff cold|4

Relative Emission|0.7

Parameter of thermal conductivity|0.5

Assign Draw Unassign Exchange

Assign Draw Unassign Exchange

Close Close

Select DRAW->all materials in the Material dialog box to display Materials
Press [Esc]| or Finish to leave
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7. Assign the general data

From the pull down menu select:
Data->Problem Data

In the Problem Data dialog mask enter:

TIMESTEP, UPTIME, TIMEPRINT as needed

Do not forget to tick the box Autorun Torsion Analysis

Also tick the box Consider reduction of torsional stiffness and leave the value as 0.1

Click on the Accept data button

Problem data n

N2 2

Title 1|Safir_Thermal
Title 2 Mesh_from_G
TETA|0.9
TINITIAL|20.0
SOLVER PARDISO
NCORES| 1
Type of calculation MAKETEM ~
Global center (Yo) |0
Global center (Zo)|0
Center of torsion(Yc) 0
0
0

Center of torsion(Zc)
NVOID

TIMESTEP |12
UPTIME|3600

TIMEPRINT |60

[ Auto run torsion anaysis and insert result in Tem file

[ iConsider reduction of torsional stiffness:

reduction coeffi'OJ

Accept Close
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8. Create the mesh

Select Mesh -> Structured -> Lines -> Assign number of cells

& Gio s Praject: RC20x30 (SAFIR2016\Safir_Thermal_2d)
Files View Geometry Utilities Data Mesh Calculate Cross-Section About Problem Type Help

Q@ (=Y ':;:\‘_‘,u(‘.}q @  Unstructured

# e Structured
oA Cartesian
o P Boundary layer »
» @ e —
L Sl Quadratic type
0 Element type -
f £ Mesh criteria » 'Y S
s Reset mesh data + N
\ a Draw » @) J
“] . < Generate mesh... Ctri-g
~ Erase
o Edit mesh
ey
a3
[
a7
= Q- Mesh eptions frem medel
a1,
Lk
<3 % C )
& r
i ¥
e i

Enter 8 as the number of cells

Enter value window n

o Enter number of cells to assign to
lines

CRR.

Assign Close

Assign to the lines that form the contour of the rebars.

Select Mesh->Generate mesh or use [Ctrl + ]
Enter 0.024 as size of elements to be generated
Validate with OK
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Mesh generation n
Enter size of elements to be generated
0.024 v

[] Get meshing parameters from model

OK Cancel

Click on View mesh to visualize the mesh

Note: the number of elements is limited here in order to be suitable for the demonstration
version of SAFIR. For users of the full version, a smaller size of elements should be
preferred for a reinforced concrete section.

9. Start the calculation

From the pull down menu select:
Calculate->Calculate window
Click the Start button

Click the Output View button

GID creates a .IN file in the project directory and starts the calculation.

In the output window you can see the calculation progress from SAFIR and the GiD
interface program which generates GiD postprocessor files from the .OUT file.
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Click on “Ok”, save, and open the postprocessor Diamond to visualize the results.

RC20:30XML - o x
File Edit Display Plot Results Options Window Help
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