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1. General description 

 

This example deals with a 3D beam of 6 m length. The beam is a W21x44 steel profile protected 

with 25.4 (1 inch) of sprayed fire resistive material (SFRM). It is exposed to the ASTM E119 

fire on its four sides. The beam is simply supported. It is subjected to a uniformly distributed 

load of 50 kN/m. 

 

 

 
 

 

Steel for W21x44:  

- Yield strength 355 MPa 

- Material model from Eurocode 3 part 1-2 

 

Thermal insulation (SFRM) 

- Thermal properties constant with temperature 
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2. Section for W21x44 steel beam 

 

2.1. Create a project for 2D thermal analysis 

 

From the pull down menu select: 

Data -> Problem type -> SAFIR2016 -> Safir_Thermal_2d 

 

 

 

To save the project select (or use icons on the left): 

Files->Save or [Ctrl + s] 

 

Enter a file name, e.g.: W21x44 

GiD creates a directory with the name W21x44.gid 

GiD creates a number of system files in this directory. 

When you start the SAFIR calculation the Safir . IN, .OUT and .TEM files will be created 

in this directory. 
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2.2. Create the geometry of the cross-section 

 

The profile is a W21x44 with dimensions given here below. 

Depth 525.8 mm 

Width 165.1 mm 

Web thickness 8.9 mm 

Flange thickness 11.4 mm 

SFRM thickness 25.4 mm 

 

We will create the steel profile section first. The profile is centered on (0, 0). Select the 

option to create system lines: 

Geometry->Create->Straight Line   or  

 

Enter in the command line (at the bottom of the widows) successively the coordinates of 

the 2 nodes that define the lines. After typing the coordinates of a node, click [Enter] to 

validate. 

 

 
 

Press [Enter] 

 

 
 

Press [Enter] 

This creates a first line based on these two points, which is the lower face of the lower 

flange. Now adding a point to create the right face of the lower flange: 

 

 
 

Press [Enter]. Then adding a point on the right side of the web: 

 

 
 

Press [Enter].  
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And so forth with the following points: 

   
 

   
 

   
 

When entering this last point, select [Join] when asked by GiD to connect with the existing 

point at these coordinates. Then press [Esc] to exit the line creation command. 

 

GiD displays the following geometry: 

 

 
 

Note: GiD offers a number of tools to create the geometry efficiently, such as the ones that 

can be accessed in Utilities->Copy… as well as the possibility to directly create objects. 

The objective here above was to show the process to create a profile line by line. Now, the 

Copy tool will be used to create the SFRM. 

 

First, select View->Label->All in->Points to display the points numbers. 

 

Select the option to copy existing model entities: 

Utilities->Copy… 
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Select Entities types: Points and Transformation: Translation.  

As first point, leave the coordinates: 0.0, 0.0. 

As second point, enter: 0.0254, 0.0254 (i.e. the thickness of the SFRM) 

Then, select the top right point of the profile (no. 7). Click on Finish or Esc to validate. 

This creates a new point (13) that is at a distance of 25.4 mm of the profile. 

 

The same translation is applied to nodes 3 and 4. 
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Then, a new translation is defined with the second point being: 0.0254, -0.0254. 

This translation is applied to nodes 2, 5 and 6.  

 

 
 

A third translation is defined with the second point being: -0.0254, 0.0254. 

This translation is applied to nodes 8, 11 and 12.  

 

Finally, translation -0.0254, -0.0254 is applied to nodes 1, 9 and 10.  

 

This procedure has created 12 new points which define the contour of the SFRM. Now, 

select the option to create system lines: 

Geometry->Create->Straight Line   or  

 

Use ctrl + A to pick an existing point with the mouse. Click successively on the points to 

create the contour of the SFRM. (For instance: 22 – 16 – 14 – 15 – 17 …).  

When it is done, click [Esc]. 
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There remains to create the surfaces.  

Select Geometry->Create->NURBS surface -> By contour  or  

 

Select the lines that form the contour of the steel profile and click Esc to validate. 

 

   
 

Then select the lines that form the contour of the SFRM (including the internal contour, i.e. 

actually all the line in the model). Click Esc to validate. 
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2.3. Assign the thermal boundary conditions 

 

In GiD, from the pull down menu select: 

Data->Conditions 

A window opens up in GiD. Select the  button (“Line”). On the first pull down list, 

select: Frontier constraints 

 

Different time-temperature curves are predefined. Select ASTME119. 

 

 
 

Click on the Assign button and assign it to the contour of the SFRM as shown below. 

 

Press [Esc] or click on Finish to confirm. 

Select DRAW->Colors in the Conditions dialog box to display the frontier constraints. 

Press [Esc] or click on Finish to leave this view mode. 

 

 
 

 

 

  



SAFIR® training session  Tutorial – 06/2018 

3D Beam  10 

2.4. Assign a torsion constraint 

 

The torsion constraint needs to be applied on a node that is on an axis of symmetry of the 

section. To create such a node, from the pull down menu select: 

Geometry -> Edit -> Divide -> Lines -> Num divisions 

 

Enter number of divisions: 2. Select the line at the top of the top flange of the profile. 

Validate with Esc. A node 25 is created. 

 

  
 

In GiD, from the pull down menu select: 

Data->Conditions 

Select the   button 

On the pull down list: Torsion constraints 

Tick the box Constraint (only in GiD problem types versions prior to 1.4) 

 

Select the node 25 on the vertical axis of symmetry of the steel profile. Validate with Finish. 

 

 

2.5. Assign the materials 

 

From the pull down menu select: 

Data->Materials 

Select STEEL from the dialog box pull down list 

The Thermal tab is active. 

Then select: 

STEELEC3EN as Material Type 
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A Convection Coeff hot of 25 

A Convection Coeff cold of 4 

A Relative Emission of 0.7 

 

 
 

Then select the Mechanical tab. Input: 

A Young modulus of 210 000 MPa 

A Poison ratio of 0.3 

A Yield strength of 355 MPa 

 

 
 

Click on Assign-> Surfaces and assign it to the W21x44 surface 

Press [Esc] or Finish to confirm. 

 

Next, select INSULATION from the dialog box pull down list 

Fill in with the following properties: 
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Click on Assign-> Surfaces and assign it to the SFRM surface.  

Press [Esc] or Finish to confirm. 

 

Select DRAW->all materials in the Material dialog box to display Materials 

Press [Esc] or Finish to leave 

 

 
 

2.6. Assign the general data 

 

From the pull down menu select: 

Data->Problem Data 

 

In the Problem Data dialog mask enter: 

TIMESTEP, UPTIME, TIMEPRINT as needed 

Do not forget to tick the box Autorun Torsion Analysis 

Also tick the box Consider reduction of torsional stiffness and leave the value as 0.1 
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Click on the Accept data button 

 

  
 

 

2.7. Create the mesh 

 

Select Mesh->Generate mesh or use [Ctrl + g] 

Enter 0.015 as size of elements to be generated (note: a coarser mesh may be required with 

the demonstration version of SAFIR. If GiD does not run, try coming back to the mesh 

definition and using 0.018 as the size). 

Validate with OK. Click on View mesh to visualize the mesh 
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2.8. Start the calculation 

 

From the pull down menu select: 

Calculate->Calculate window 

Click the Start button 

Click the Output View button 

 

GiD creates a .IN file in the project directory and starts the calculation. 

In the output window you can see the calculation progress from SAFIR and the GiD 

interface program which generates GiD postprocessor files from the .OUT file. 

 

Click on “Ok”, save, and open the postprocessor Diamond to visualize the results. 

 

 
 

 

 

The .tem file of this model (’w21x44.tem’) will need to be copy-pasted in the folder with 

the structural model. 
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3. Create model for the 3D structure 

 

3.1. Create a new project for structural 3D analysis 

 

From the pull down menu select: 

Data->Problem type->SAFIR2016->Safir_Structural_3d 

 

  
 

To save the project select (or use icons on the left): 

Files->Save   or   or [Ctrl + s] 

 

Note: If Caps lock is active on your keyboard, shortcut do not work 

 

Enter a file name, e.g.: 3DBeam 

GiD creates a directory with the name 3DBeam.gid 

GiD creates a number of system files in this directory. 

When you start the SAFIR calculation the Safir .IN and .OUT files will be created in this 

directory. 

 

 

3.2. Copy-Paste the section file in the structural analysis directory 

 

GiD has created the directory 3DBeam.gid 

 

The structural input file, which will be created in this directory, will require the information 

from the section files. Therefore, these sections files need to be located in the same directory. 

 

Copy and paste the files ‘W21x44.tem’ in the directory 3DBeam.gid 
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3.3. Create the system geometry (3D beam) 

 

The view is by default in the x-y plane. Here, the plane of the frame will be defined in the 

x-z plane. To change to the 3d isometric view select from the pull down menu: 

View->Rotate->isometric 

Or if you want to define a point of view by your own use: 

View->Rotate->Trackball   or [F7]   or  

 

Create the system lines: 

Geometry->Create->Straight Line   or  

 

Enter in the command line (at the bottom of the widows) successively the coordinates of 

the 2 nodes that define the beam. After typing the coordinates of a node, click [Enter] to 

validate. 

 

 
 

Press [Enter] 

 

 
 

Press [Enter] 

Then press [Esc] to leave the line creation menu. You should see this in GiD: 

 

 
  

To see nodes and beams numbers select: 

View->Label->All  
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3.4. Define constraints for the supports 

 

From the pull down menu select 

Data->Constraints 

Select Point Constraints 

Tick the boxes for X-constraint, Y-constraint, Z-constraint, and ROTX constraint. Assign 

these constraints to POINT 1 and press [Esc]. 

 

 
 

Then, tick the boxes for Y-constraint and Z-constraint and assign these constraints to 

POINT 2 and press [Esc]. 

 

  
 

In the dial box, with Draw->Colors you can display the constraints. 

Press Finish or [Esc] to leave this view mode.  
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3.5. Assign the loads 

 

From the pull down menu select 

Data->Loads 

 

Assign a distributed load of -50 000 N/m in Z direction on the beam.  

Use the function FLOAD. 

Press Finish or [Esc] to validate. 

 

  
 

 

4.6. Create Local Axes 

 

Local Axes: The orientation of the cross-section is controlled by defining a local axes X’Y’Z’ 

–system. 

 

 
 

Unlike SAFIR which needs a 4th node to describe the orientation of a cross section on a beam, 

the GiD-SAFIR interface uses a local X’Y’Z’ axes system. When you start the SAFIR calculation 

the GiD-SAFIR Interface creates the 4th node in the X’Y’ plane. If the center of the local axes 

is not located on the system line of the beam, the direction vector of the Y’-axis is used together 

with the starting point of the beam to define the 4th node. However the GiD-SAFIR interface 

will issue a warning message in the Viewoutput window of the calculation run. 
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From the pull down menu select: 

Data->Local Axes->Define 

 

Enter the name of the local axis LAX 

Select 3 points XZ 

 

 
 

Select Point 1 as the local axis center. Note: Press “CLTR + A” to allow the selection of an 

existing point with the mouse. 

Select Point 2 as the point in positive x axis. 

The third node points to the positive direction along the z axis. There is no such node available 

in the model. You have to enter coordinates manually. 

 

 
 

Press Enter 

 

To draw local axes select: 

Data->Local Axes->Draw all  
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4.7. Define the global materials 

 

From the pull down menu select 

Data->Material 

 

There are 2 materials in the model: 

- The steel for the profile W21x44: STEELEC3EN 

- The insulation for the SFRM: INSULATION 
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4.8. Define the properties (i.e. assign temperature files) 

 

From the pull down menu select 

Data->Properties 

 

The objective is to assign the .tem file named w21x44 to the model line. In the dial box of 

Data->Properties, change the File-Name: safir.tem to the temperature file (.TEM file) of 

the cross-section, in this case w21x44.tem. 

 

Change Local-Axes from -Automatic- to LAX 

Change the number of materials to 2.  

Assign the w21x44.tem section to the beam. 

 

   
 

You can draw the local axes of the beams to check the model. 

Select Draw -> All Conditions -> Include Local Axes 

 

 

4.9. Assign the mass 

 

To define the mass for dynamic calculation, select from the pull down menu: 

Data-> Mass 

Select Mass on Beam and put 100 kg/m as Distributed-Beam-Mass and 2 as Rotational-

Inertia. Assign to the beam. 
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4.10. Define the general problem data 

 

Select from the pull down menu: Data->Problem Data 

And fill as shown below 

    
 

 

4.11. Define the mesh 

 

Select Mesh -> Structured -> Lines -> Assign number of cells 
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Assign 10 elements. Select the line. Press [Esc] to validate. 

 

 
  

Select Generate Mesh and then View Mesh 

 

 

4.12. Start the calculation 

 

From the pull down menu select: 

Calculate->Calculate window 

Click the Start button 

 

You can follow the progress of the calculation by clicking on Output view or by selecting 

Calculate->View process info 

 

 

4.13. Check the results 

 

Open the .XML file in Diamond to check the model. Plot the support conditions, applied loads, 

deflected shape, membrane forces, etc. 

 

        


