SAFIR® training session

Tutorial — 06/2018

SAFIR® training session — level 1
Johns Hopkins University, Baltimore

Example: 3D structural model of a frame
“3D frame with concrete columns and a steel beam”

T. Gernay & J.M. Franssen

(=]

3D Frame



SAFIR® training session Tutorial — 06/2018

1. General description
This example deals with a 3D frame of 3 m height and 8 m length. The columns are reinforced
concrete section of 30 cm x 30 cm, with 4 @20 steel bars with an axis cover of 30mm, heated

on 3 faces. The beam is a IPE 300 steel profile, heated on 3 faces. The columns are fixed and
the frame is subjected to a combination of distributed loads and point loads as shown below.

20kN 20kN

20kN

Steel for IPE300:
- Yield strength 355 MPa

Steel for reinforcement bars:
- Yield strength 500 MPa

Concrete:
- Compressive strength 30 MPa
- Tensile strength 1 MPa
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2. Section for IPE300 steel beam

The model created in a previous exercise will be used here.

The .tem file of this model ("ipe300.tem ) will need to be copy-pasted in the folder with
the structural model.

3. Section for concrete column

The model created in a previous exercise will be used here.
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The .tem file of this model ('7¢30x30.tem”) will need to be copy-pasted in the folder with
the structural model.
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4. Create model for the 3D structure
4.1. Create a new project for structural 3D analysis

From the pull down menu select:
Data->Problem type->SAFIR2016->Safir_Structural_3d

'ﬁ Safir_Structural_3D x64 Project: UNNAMED (SAFIR2016\5afir_Structural_3d)
Files View Geometry Utilities Data Mesh Calculate Structure Help

0 © @ | N ______'_‘e—} Problem type ansys55 » @ | @ ? | Q

X i Caltep
- 9 Constraints EBxamol .
amples
y
= u Loads Fluent
o — Properties Openfoam
a & E SAFIR2016 Safir_Structural_2d
&O,Ij Mass 3 SAP2000 v Safir_Structural_3d
{) oroblem Dot S Safir_Thermal_2d
/ £J roblem Data ran: om,... Safir Thermal_3d
. Internet retrieve... .
™ % Material Load. Safir_Thermal_tsh
_— oad...
I p Unload
Rel
~ _‘ % feese Debugger...
1 Local axes » I
— a1

To save the project select (or use icons on the left):

Files->Save or © or [Ctrl + s]
Note: If Caps lock is active on your keyboard, shortcut do not work
Enter a file name, e.g.: 3DFrame
GID creates a directory with the name 3DFrame.gid
GID creates a number of system files in this directory.
When you start the SAFIR calculation the Safir .IN and .OUT files will be created in this
directory.
4.2. Copy-Paste the section files in the structural analysis directory

GID has created the directory 3DFrame.gid

The structural input file, which will be created in this directory, will require the information
from the section files. Therefore, these sections files need to be located in the same directory.

Copy and paste the files ‘ipe300.tem’ and rc30x30.tem’ in the directory 3DFrame.gid
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4.3. Create the system geometry (3D structure)

The view is by default in the x-y plane. Here, the plane of the frame will be defined in the
X-z plane.

To change to the 3d isometric view select from the pull down menu:
View->Rotate->isometric

Or if you want to define a point of view by your own use:

View->Rotate->Trackball or [F7] or 0

Create the system lines:
Geometry->Create->Straight Line or
Enter in the command line (at the bottom of the widows) successively the coordinates of

the 4 nodes that define the frame in the command box. After typing the coordinates of a
node, click [Enter] to validate.

Leaving line creation. 0 new lines
Enter points to define line (ESC to leave)

Command; |D o0

- L]

Press [Enter]

Command: (003

Press [Enter]
Command: E
Press [Enter]
Command: (2800

Press [Enter]
Then press [Esc] to leave the line creation menu.

You should see this in GiD:
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& Safir_Structural 30 x64 Project: 3DFrame (SAFIR2016\Safir_Structural_3d)
Files View Geometry Utilities Data Mesh Calculste Structure About Problem Type Help
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Leavi ine creation. 3 new lines

Enter points to define line (ESC to leave)

HEE Y

Command: |

To see nodes and beams numbers select:
View->Label->All

4.4. Define constraints for the supports

From the pull down menu select

Data->Constraints

Select Point Constraints

Tick all the boxes for a fully fixed condition. Assign these constraints to POINT 1 and
POINT 4 and press [Esc].

Constraints ﬂ
3™\,

1
Point-Constraints v | @

[¥] X-Constraint:
[ ¥-Constraint:
Z-Constraint:
ROTX.Constraint:
ROTY.Constraint:

Assign Entities Draw Unassign

Close

In the dial box, with Draw->Colors you can display the constraints.
Press Finish or [Esc] to leave this view mode.

3D Frame 6



SAFIR® training session Tutorial — 06/2018

4.5. Assign the loads

From the pull down menu select
Data->Loads

4.5.1. Punctual load at the top of the columns

Assign a punctual load of 20 000 N in X and Y directions on node 2. Use the function
FLOAD so the load is applied gradually over the first 20 seconds of the simulation.

E Safir_Structural_3D x64 Project: 3DFrame (SAFIR2016\Safir_Structural_3d)
Files View Geometry Utilities Data Mesh Calculate Structure AboutProblem Type Help

Ceo|BRLEP DR QD aw S|l e?7|H
e 9

X7 2 '

B!
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A |
-7,!'2 Finish Press ‘Finish' 1o er ,__J 3
E\L“i{ Close
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Enter Points with new values
Added 1 new points to the selection. Enter more points. (ESC to leave)

Press Finish or [Esc] to validate.

Assign a punctual load of 20 000 N in Y direction on node 3. Press Finish or [Esc].
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4.5.2. Distributed load on the beam

Assign a distributed load of -10 000 N/m in Z direction on the beam. Press Finish or
[Esc] to validate.

Loads n /,2

e 7
> SRS

Beam-Load v‘ N? g P L
X Pressure|0.0
Y Pressure|0.0 2 !
Z Pressure|-10000.0

LOAD FUNCTION FLOAD -

Assign Entities Draw  Unassign

Close

4.5.3. Punctual load at mid-span of the beam

First, create a node at mid-span of the beam.
Use Edit -> Divide -> Lines -> Num divisions: 2

Safir_Structural_30 x64 Project: UNNAMED (SAFIR20164\5afir_Structural_3d)
Files View Geometry Utilities Data Mesh Calculate Structure Help
i A

O T @ Viewgeometry Al Lo & #2249
c@ & Create L4
(g@ |Z & Delete ’
é@ Edit Maove point l

Divide *. Lines Mum divisions
o 3 b 2] Polyli Near poi 3
2 lo r+ + Polylines ear point
0 | Lines operations P |0 Surfaces 4 Parameter
/, El Swap arc @ Velumes 4 Relative Length
o % Paolyline L4 Length
NRE S

Enter value window n

9 Enter number of divisions

E |

Ok | Cancel

-

3D Frame 8



SAFIR® training session Tutorial — 06/2018

After clicking on OK, select the line 2 to divide.

Once the line selected, press [Esc] to validate. GiD creates a new node at the center of
the line. This node is numbered 5.

Now back in Loads, assign a punctual load of -20 000 N in Z direction on node 5.

Al wGdgE
@RRIhng®|

1

/

< ‘.:‘).‘J |F’ i
BpParR b9 Adl

Finish Press ‘Finish’ to end se 7

2
)

Finally, you can check the applied loads by drawing them:

Loads n

. B
Point-Load v‘ x?
X-Force|0.0
¥-Force|0.0
Z-Force|-20000.0
X-Moment|0.0
Y-Moment| 0.0
Z-Moment|0.0
LOAD FUNCTION FLOAD -

Assign Entities Draw  Unassign

All Loads
Close B
Point-Load
Colors
All conditions »

Field's value *

Field's color *
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4.6. Create Local Axes

Local Axes: The orientation of the cross-section is controlled by defining a local axes X’Y’Z’
—system.

Global axes system

Beam

Local axes system

Unlike SAFIR which needs a 4th node to describe the orientation of a cross section on a beam,
the GiD-SAFIR interface uses a local X’Y'Z’ axes system. When you start the SAFIR calculation
the GiD-SAFIR Interface creates the 4th node in the XY’ plane. If the center of the local axes
is not located on the system line of the beam, the direction vector of the Y’-axis is used together
with the starting point of the beam to define the 4th node. However the GiD-SAFIR interface
will issue a warning message in the Viewoutput window of the calculation run.

The objective is to create 3 local axes (LAX, LAZU, LAZD) as shown in the figure below.

From the pull down menu select:
Data->Local Axes->Define
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Enter the name of the new local axe LAZD
Select 3 points XZ

Dialog window n
o Choose definition mode or delete

Xand Angle Delete

Cancel

Select Point 2 as the local axis center. Note: Press “CLTR + A” to allow the selection of an
existing point with the mouse.

Select Point 1 as the point in positive x axis.

The third node points to the positive direction along the z axis. There is no such node available

in the model. You have to enter coordinates manually.

->013
Entered new Local axes definition. Leaving

Command: |D1 3|

Zoom: 1x

Press Enter
You should see this in GiD. This local axis LLAZU will be used for the column 1.
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Repeat the operations to create the local axe LAZU

Select Point 4 as the local axis center.

Select Point 3 as the point in positive x axis.

For the third node (point in positive z axis), use the following coordinates:

End joining. Enter new Points
Enter point in positive Z axis (the point will be exactly inside the axes)

Command: |31 0

Zoom: 1x MNodes: 0, Eler

Press Enter
You should see this in GiD. This local axis LAZU will be used for the column 3.

Finally, repeat the operations to create the local axe LAX

Select Point 5 as the local axis center.

Select Point 2 as the point in positive x axis.

For the third node (point in positive z axis), use the following coordinates:

End joining. Enter new Points
Enter point in positive Z axis (the point will be exactly inside the axes)

Command: |4 1 3|

Foom: Tx

Press Enter

To draw local axes select:
Data->Local Axes->Draw all
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4.7. Define the global materials

From the pull down menu select
Data->Material

There are 3 materials in the model:

- The steel for the profile IPE300: STEELEC3EN

- The steel for the reinforcement of the concrete columns: STEELEC2EN
- The concrete for the columns: SILCON_ETC

In the section IPE300: MAT 1 =STEELEC3EN
In the section RC30x30: MAT 1 = STEELEC2EN, MAT 2 = SILCON_ETC

Diamond 2016 for SAFIR Diamond 2016 for SAFIR
FILE : IPE300 FILE : RC30x30

NODES : 348 NODES : 272

SOLIDS : 458 SOLIDS : 491

SOLIDS PLOT SOLIDS PLOT

SOLIDS : SOLIDS :

[ STEELEC3EN [ STEELEC2EN

[ SILCON_ETC

In the structural model, we decide that the order is:
MAT 1 = STEELEC3EN
MAT 2 = STEELEC2EN
MAT 3 =SILCON_ETC

Material

ol -

Temperatures | General | Materiall | Material2 | Material3

Mumber of materials 3 -

Close
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Material

L -]

Temperatures | General | Materiall || Material2 | Material3 |

Materiall STEELEC3EN ~
Mat1 E-Modulus|2.1e11
Mat1 Poisson ratio|0.3
Mat1 Yield strength|3.55e8
Mat1 Max Temperature|1200.
Mat1 Rate Decrease Yield Strength (0.

Material

© @

Temperatures | General | Materiall | Material2 || Material3 |

Material2 STEELEC2EN ~
Mat2 E-Modulus|2.1e11
Mat2 Poisson ratio (0.3
Mat2 Yield strength|5.0e8
Mat2 Max Temperature| 1200,
Mat2 Rate Decrease Yield Strength|0]
Mat2 Process Fabrication HOTROLLED ~
Mat2 Class Ductility CLASSB ~

Accept Close

Material

© @3

Temperatures | General | Materiall | Material2 | Material3

Material3 SILCONETC ~

Mat3 Poisson ratio|0.2
Mat3 Compressive strength|3.0e7
Mat3 Tension strength|1.0e]

Accept | Close

Note: a description of the material SILCON_ETC is given in the following paper:

Gernay, T., & Franssen, J. M. (2012). A formulation of the Eurocode 2 concrete model at
elevated temperature that includes an explicit term for transient creep. Fire Safety Journal, 51,
1-9.
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4.8. Define the properties (i.e. assign temperature files)

From the pull down menu select
Data->Properties

The objective is to assign the .tem file named ipe300 and rc30x30 to the model lines.

OIRREE BRIRD e WS B2/ &

Properties B
»? 2 /
> )
/)/'
Nus > i
>
>
A
//.
./'/
y
Finish | F /-/
2
Clos 7
5 I ipe3ootemLAX 11234
[ rc30x30.tem LAZD 223 3 4
v B c30x30.temLAZU 22334

Now on, conditions will be drawn by color

press ‘escape’to lesve

In the dial box of Data->Properties, change the File-Name: safir.tem to the temperature
file (TEM file) of the cross-section, in this case ipe300.tem.

Change Local-Axes from -Automatic- to LAX
Keep the number of materials to 1. The Mat1 Global Nr is 1 (it is the STEELEC3EN).
Assign the ipe300.tem section to the beams 4 and 5 (the horizontal beams of the frame).

Properties n

e
AV
1

BEAM Cross Section v‘ N2 3

File-Name|ipe300.tem e o

Local-Axes LAX v

Number of materials 1~
Mat1 Global Nr|1 P
Mat2 Global Nr 2 P -
Mat3 Global Nr 3 e
Mat4 Global Nr 4 e

Assign Entities Draw Unassign

Close A
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Then, change the file name to rc30x30.tem. Change Local-Axes to LAZU. Specify 2 materials.
The Matl Global Nr is 2 (it is STEELEC2EN). The Mat2 Global Nr is 3 (SILCON_ETC).
Assign to column 3.

nes

pe
pue——
¥

BEAM Cross Section v ‘ K2 3 v
File-Name |rc30x30.tem
Local-Axes LAZU -

Number of materials 2
Mat1 Global Nr
Mat2 Global Nr|3

r

Assign Entities Draw Unassign

Close

Finally, keep the file name to rc30x30.tem but change Local-Axes to LAZD. Keep 2 materials
with Mat1 Global Nr is 2 and Mat2 Global Nr is 3. Assign to column 1.

Properties n
BEAM Cross Section ‘| e @ yd
File-Name|rc30:30.tem | A
Local-Axes LAZD v
Number of materials 2~ &
Mat1 Global Nr|2
3 5

Mat2 Global Nr

Assign Entities Draw Unassign

Close

You can draw the local axes of the beams to check the model.
Select Draw -> All Conditions -> Include Local Axes
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=) !
Files View Geometry Utilities Data Mesh Calculate Structure About Problem Type Help
COR|RRRF BR|IPD Ly EEIRCR AL |
» e
~Ver
i
8 a Properties B
{5 i s Loint-Load
0 = BEA 2
{ g ¢ o N
. - SEAN Doads Sc, Cross Section
_\\ .$ Nu “z -
)5
.A:V.:' %1 HaintLoad vint-Constraints
| ﬁ ~
W s _$EAM-Dsads Section
-2 [ Finish " Finish' to end z
A
- (2' g Jui’nl Load
- -
&,
\A % $3EAM Cross Section
*® ¥ u
&
;?; . Moint-Constraints
v

by
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2
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Now on, conditions and local axes will be drawn
press 'escape’ to leave

4.9. Assign the mass

To define the mass for dynamic calculation, select from the pull down menu:

Data-> Mass

Select Mass on Beam and put 100 kg/m as Distributed-Beam-Mass and 2 as Rotational-
Inertia. Assign to all the beam elements.

Mass for Dynamic Calculation

Mass CI:I Be;m v] x? @

Distributed-Beam-Mass| 100.0
Rotational-Inertia | 2.0

Assign Entities Draw Unassign

Close
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4.10.

Define the general problem data

Select from the pull down menu: Data->Problem Data
And fill as shown below

General

2

Calculation parameters | Output optional results |

Title 1
Title 2
SOLVER

e —

Loads

Convergence

TIMESTEPMIN[0.002 |

[[] Consider max displacement

PRECISION
NGEOBEAM
NG
NFIBERBEAM
NGEOTRUSS
NGEOSHELL
NGSHELLTHICK
NREBARS
TIMESTEP
UPTIME
TIMESTEPMAX
TIMEPRINT

Safir_Static_3[

Mesh_from_G
PARDISO ~

DYNAMICPURENR  ~
COMEBACK ~

1.0e-3

2
2

2000

0

4.11.

Define the mesh

General

A2
Calculation parameters ~ Output optional results |
[] PRINTTMPRT Print temperatures in the fibers
[C] PRINTVELAC Print velocity and acceleration
PRINTREACT Print reactions
[ PRINTMN Print internal forces of beams
[[] PRNEIBEAM Print stiffness in beams
[C] PRINTSHELL Print stresses in shell elements
[] PRNNXSHELL Print membrane forces in shell elemen
] PRNMXSHELL Print bending moments in shell eleme
[C] PRNEASHELL Print membrane stiffness in shell eleme
[T] PRNEISHELL Print Bending stiffness in shell elements
[] PRNSTRAIN Print strains and stresses in shell elemen

Select Mesh -> Structured -> Lines -> Assign number of cells

& safir_Structural_30 x64

Files View Geometry Utilities Data

Project: frame (SAFIR20-16\Safir_Structural_3d)

Mesh  Calculste Structure  About Problem Type Help

OO D| BB o] Ui QR IR AR
e Structured . Lines Assign number of cells
SemiStructured ¥ [J Surf ¥|  Assign size
PF Cartesian ]
o T »
2
‘;’ i Quadratic type »
i Element type »
/ﬂ‘ & Mesh criteria »
S Reset mesh data
\ Draw 3
a;, <% Generate mesh... Ctrl-g
~ Erase mesh
(\‘33 = Edit mesh »
J@ Show errors
=4 View mesh boundary -
ﬂ % Create boundary mesh
—i] 2 Mesh quality... -
il‘ 2. Mesh options from model
a0
X
~8
$p -
pod
=3
e
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Assign 10 elements. Select all the lines. Press [Esc] to validate.

Enter value window n

0 Enter number of cells to assign to
lines

10

Assign Close

Select Generate Mesh and then View Mesh

Progress in meshing

Mesh generated.

Num. of Linear elements=40
Num, of nodes=41

Num nodes Meshing evolution
Memory KB
10000
9000

m,

7000

6000

50004

40004

30001

2000+

1000

0 1 2 3 4 5 6 7 8 9 10
Time (seconds)

Close
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412, Start the calculation
From the pull down menu select:
Calculate->Calculate window

Click the Start button

You can follow the progress of the calculation by selecting Calculate->View process info

4.13. Check the results

Open the . XML file in Diamond to check the model. Plot the support conditions, applied loads,
deflected shape, membrane forces, etc.

3DFrame. XML _ a "
Results :
Displacement Displacements
DOF :
== Node 21
3
Nodes
Plotted Net plotted 005
Node 21 Node 13
Node 14
Node 15
. Node 16
Node 17 014
Node 18
= Node 1%
Node 20
Node 22
Node 23 0159
Add 1o selection: Add to selection:
#| #
Export/Print z
Export To Image Print -
b
Zoom -0.2

Adjust zoom to series

Data
Copy data from chart

035

T T T T T T T T T T T T T T
50 100 150 200 250 300 350 400 450 500 550 600 650 T00
Time [sec]

3D Frame 20



