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1. General description 

 

This example deals with a steel-concrete structure. A reinforced concrete slab is supported by 

peripheral and central steel beams. The structure is simply supported at its four corners.  

 

General data: 

- 15 m by 12 m plane dimensions 

- Reinforced concrete flat slab of 0.16 m thickness 

o Two layers of orthogonal steel mesh (393 mm²/m per layer per direction) 

- Protected (cold) peripheral steel beams IPE550 

- Two unprotected (hot) central steel beams IPE550 

o The central beams span 15 m and are spaced by 4 m 

- Simply supported 

- Fire: natural fire curve with a cooling phase 

- Loads: uniform distributed load 

 

 

 
 

Concrete: 

- Compressive strength 30 MPa 

- Tensile strength 0.5 MPa 

 

Steel for IPE550: 

- Yield strength 355 MPa 

 

Steel for reinforcement bars: 

- Yield strength 500 MPa 
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2. Create section for IPE550 steel beam 

 

The objective is to create a IPE550 section with a slab, exposed to the natural fire curve. 

 

The section file has to be created for a subsequent 3D structural analysis. Therefore, it will 

also include a torsional analysis. 

 

 

2.1. Create a project in 2D for Thermal Analysis 

 

From the pull down menu select: 

Data -> Problem type -> SAFIR2016 -> Safir_Thermal_2d 

 

 

 

To save the project select (or use icons on the left): 

Files->Save or or [Ctrl + s] 

 

Enter a file name, e.g.: IPE550 

GiD creates a directory with the name IPE550.gid 

GiD creates a number of system files in this directory. 

When you start the SAFIR calculation the Safir . IN, .OUT and .TEM files will be created 

in this directory. 

 

 

2.2. Create the geometry in the xy-plane 

 

From the pull down menu select: 

Cross-Section->I-Profile 
 

Select IPE as type, IPE 550 as Profile, tick exact shape, put 1000 mm as slab width 

and a slab height of 160 mm 

Click on Apply 
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Note: GiD-Safir will create an IPE550 profile. The center of this profile will be 

automatically centered on the 0,0 point of the xy-plan. 
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2.3. Create and assign a temperature curve 

 

In this exercise, we will suppose that you want to import your own fire curve of temperature. 

In order to permit to GiD-Safir to use your data, you have to first create a .txt document. 

Open your Notepad and wrote as many line as necessary, each line being, in a free format, 

a pair of values in the form: 

     TIME        TEMPERATURE 

 

Save the file created. Here, we are going to save under the name: Fire.txt 

Then copy the Fire.txt file in the IPE550.GiD file you just created. 

 

 
 

In GiD, from the pull down menu select: 

Data->Conditions 

Select the  button 

On the first pull down list: Frontier constraints 

On the Temperature curve pull down list USER 

 
Write the File name of user temperature curve in the dial box (Fire.txt in this example).  
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Click on the Assign button and assign it to profile and slab lines as shown below. 

 

  
 

Press [Esc] or click on Finish to confirm 

Select DRAW->Colors in the Conditions dialog box to display the frontier constraints 

Press [Esc] or click on Finish to leave this view mode 

 

Then select F20 as temperature curve 

 
 

And assign it to the upper line of the slab, as shown below: 
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2.4. Assign a torsion constraint (for the torsional analysis) 

 

In GiD, from the pull down menu select: 

Data->Conditions 

Select the   button 

On the pull down list: Torsion constraints 

 

 
 

Select the node on the vertical axis of symmetry of the steel profile, at the connection with 

the slab (see below). Validate with Finish. 

 
  



SAFIR® training session  Tutorial – 06/2018 

3D Membrane  8 

 

2.5. Assign the materials 

 

From the pull down menu select: 

Data->Materials 

Select STEEL from the dialog box pull down list 

The Thermal tab is active. 

Then select: 

STEELEC3EN as Material Type 

A Convection Coeff hot of 35 

A Convection Coeff cold of 4 

A Relative Emission of 0.7 

 

 
 

Then select the Mechanical tab. Input: 

A Young modulus of 210 000 MPa 

A Poison ratio of 0.3 

A Yield strength of 355 MPa 

 
 

Click on Assign-> Surfaces and assign it to the IPE550 surface 

Press [Esc] or Finish to confirm 
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Select CONCRETE from the dialog box pull down list. Then fill as below: 

  
 

Note: The compressive strength has been divided by 106 (value: 30 N/m²). This is because 

the mechanical properties input here are used for the torsional analysis. In this torsional 

analysis, we want to consider the stiffness of the beam only (not the slab), because, in the 

structural model, the slab will be modeled by shells. In the concrete model, the Young 

modulus is calculated from the compressive strength; hence, reducing the strength 

automatically reduces the stiffness. 

 

Click on Assign-> Surfaces and assign it to the slab surface 

Press [Esc] or Finish to confirm 

 

Select DRAW->all materials in the Material dialog box to display Materials 

Press [Esc] or Finish to leave 

 

 



SAFIR® training session  Tutorial – 06/2018 

3D Membrane  10 

 

2.6. Assign the general data 

 

From the pull down menu select: 

Data->Problem Data 

 

In the Problem Data dialog mask enter: 

TIMESTEP, UPTIME, TIMEPRINT as needed 

Do not forget to tick the box Autorun Torsion Analysis 

Also tick the box Consider reduction of torsional stiffness and leave the value as 0.1 

 

 
 

Click on the Accept data button 

 

Note: The global center of coordinates (0,0) is by default positioned at the center of the steel 

profile. This position can be adjusted here to consider the relative position of the steel profile 

with respect to the rest of the structure in the structural model. This will be discussed later 

when defining the structural model. 

 

Note2: In this case we are using a temperature curve with user’s values. As you can see in 

the Fire.txt file, the last time step is at 10800s. The UPTIME have to be lower or equal to 

this value. 
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2.7. Create the mesh 

 

We will assign 10 elements over the slab thickness to reduce the skin effect. 

 

Select Mesh->Structured->Surfaces->Assign number of cells 

Select the slab surface, press [Esc] to validate 

Enter 10 as the number of cells to assign to lines 

Select the left vertical line of the slab and press [Esc] to validate 

 

 
 

Select Mesh->Generate mesh or use [Ctrl + g] 

Enter 0.03 as size of elements to be generated 

Validate with OK 

 

 
 

Click on View mesh to visualize the mesh 
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2.8. Start the calculation 

 

From the pull down menu select: 

Calculate->Calculate window 

Click the Start button 

 

Click the Output View button 

GiD creates a .IN file in the project directory and starts the calculation. 

In the output window you can see the calculation progress from SAFIR and the GiD 

interface program which generates GiD postprocessor files from the .OUT file. 

Once the calculation is done, you can open the .XML file with DIAMOND. 
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3. Create section for concrete slab 

 

3.1. Create a project in 2D for TSH thermal analysis 

 

From the pull down menu select: 

Data->Problem type->SAFIR2016->Safir_Thermal_TSH 

 

 
 

To save the project select (or use icons on the left): 

Files->Save   or   or [Ctrl + s] 

 

Note: If Caps lock is active on your keyboard, shortcut do not work 

 

Enter a file name, e.g.: Slab16 

GiD creates a directory with the name Slab16.gid 

GiD creates a number of system files in this directory. 

When you start the SAFIR calculation the Safir .IN, .OUT and .TSH files will be 

created in this directory. 

 

Copy the file Fire.txt file in the Slab16.GiD directory you just created. 

 

 

3.2. Create the geometry (slab cross section) in the xy-plane 

 

GiD will open automatically a new window. 

Put 0.16 m as shell thickness and 20 as number of elements, as shown below: 
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Click on Apply 

 

 
 

Note that the section is centered with respect to the y-axis.  

It means that in the structural model, the nodeline of the shell elements is located at mid-height 

of the section (if no modification of the nodeline is made by the user). 

 

 

3.3. Assign the thermal boundary conditions 

 

From the pull down menu select:  

Data->Conditions 

 

 
 

Select: 

On the first pull down list: Frontier constraints 

On the Temperature curve pull down list USER 

Write the File name: Fire.txt 
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Click on the Assign button and assign it to the lower line as shown below. 

 

 
 

Press [Esc] or click on Finish to confirm 

 

Next, select: 

On the Temperature curve pull down list F20 

Click on the Assign button and assign it the upper line as shown below 

 

 



SAFIR® training session  Tutorial – 06/2018 

3D Membrane  16 

 

Select DRAW->Colors in the Conditions dialog box to display the frontier constraints 

Press [Esc] or click on Finish to leave this view mode 

 

 
 

You will need to have the file Fire.txt file in the Slab16.GiD directory for the analysis to run. 

 

 

3.4. Assign materials 

 

From the pull down menu select: 

Data->Materials 

Select CONCRETE from the dialog box pull down list 
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Then select: 

SILCON ETC as Material Type 

A specific mass of 2400 

A moisture content of 48 

A Convection Coeff hot of 35 

A Convection Coeff cold of 4 

A Relative Emission of 0.7 

A Parameter of thermal conductivity of 0.5 

 

Click on Assign-> Surfaces and assign it to the surface 

Press [Esc] or Finish to confirm 

 

Note: a description of the material SILCON ETC is given in the following paper (for the 

mechanical behavior). Please cite this paper when using SILCON ETC or CALCON ETC.  

Gernay, T., Franssen, J.-M. (2012). A formulation of the Eurocode 2 concrete model at elevated 

temperature that includes an explicit term for transient creep. Fire Safety Journal, 51, 1-9. 

http://hdl.handle.net/2268/114050 

 

Select DRAW->all materials in the Material dialog box to display Materials 

Press [Esc] or Finish to leave 

 

 
 

 

3.5. Define the general problem data 

 

From the pull down menu select: 

Data->Problem Data 

 

In the Problem Data dialog mask enter: 

TIMESTEP, UPTIME, TIMEPRINT as needed 

http://hdl.handle.net/2268/114050
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Click on the Accept data button 

 

 
 

Note: When you click with the left button on one of the variables, GiD will display a short 

description of the variable. The variables are also described in more detail in the SAFIR manual. 

 

Click on the Rebar-Layer-Local tab and fill as shown below: 

 

 
 

Rebars-Local is the number of rebar layers in the section type. Here it is equal to 4, because the 

mesh consists in one upper layer and one lower layer in each orthogonal direction. 
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Rebar-Local1 MATERIAL is the local material number of the layer 1. In this case it is equal to 2 

(concrete is material 1, steel is material 2). The rebar material type will have to be defined later 

for the mechanical calculation. 

 

Rebar-Local1 SECTION is the cross sectional area of the rebars in this layer 1 in [m²/m]. In this 

case, it is equal to 393 mm²/m, assuming a 200mm x 200mm grid with a rebar diameter of 

10mm: 

Section = π * (0.010²/4) / 0.200 = 393 e-6 m²/m 

 

Rebar-Local1 LEVEL is the position of this layer in y axis with respect to the thickness (the 

TSH section is by default centered in y-axis). Here the cover from lower face to rebar axis is 

35 mm; therefore the LEVEL is –(0.080-0.035) = -0.045 

 

The same data has to be input for the other layer: Rebar-Local2-3-4 (because here the mesh is 

equal in both directions and both upper and lower layers), but with an angle of 90° (orthogonal) 

and a position of 0.045 for the upper layer. 

 

Click Accept and then Close. 

 

Note that alternatively, you can define the rebars in the global axes. 

In that case, click on the Rebar-Layer-Global tab and fill as shown below. 

 

  



SAFIR® training session  Tutorial – 06/2018 

3D Membrane  20 

 

Rebar-Global1 N1-N3 defines a vector in the global system of coordinates of the structure. The 

rebars have the orientation of the line which is the intersection between the shell element and a 

plane that is perpendicular to the vector (see SAFIR manual). 

If the norm of the vector is 0, then the orientation of this bar layer is perpendicular, in each 

element, to the previous bar layer (not possible for bar layer 1). 

Here, considering that the shell elements will be defined in the plane x-y in the global system 

of coordinates, the first vector is given by <1,0,0>. As a result, the rebar layer will be oriented 

in the direction parallel to the global y-axis. 

 

 

3.6. Define the mesh 

 

To create meshes select from the pull down menu: 

Mesh->Generate mesh   or use [Ctrl + g] 

 

The number of elements will be as already defined above. 

 

Note: In .TSH thermal analysis, the heat transfer is unidirectional across the thickness of the 

shell element. Therefore, only 1 FE is used on the width (i.e. in x-direction). Also, the width is 

irrelevant for the calculation (whether it is 1 m or 0.1 m will have no impact on the calculation). 

 

  
 

 

 

3.7. Start the calculation 

 

From the pull down menu select: 

Calculate->Calculate window 

Click the Start button 
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GiD creates a .IN file in the project directory and starts the calculation. 

In the output window you can see the calculation progress from SAFIR and the GiD interface 

program which generates GiD postprocessor files from the .OUT file. 

 

 

3.8. Debug - Check the results 

 

If there is an error message, or the calculation did not run properly: 

- Check that GiD has created a .IN file in the project directory 

- Check that a .OUT file is also present in the project directory 

- Open the .OUT file, go to the end of the file and check whether there is an error message 

- It is also interesting to look at the .IN file line by line, with the help of the SAFIR 

manual, to verify whether the model is correct 

 

When the calculation has run properly, a .OUT and a .XML files have been created which 

contain the results. You can open the .XML file using DIAMOND. There, you can check the 

geometry, the mesh, the thermal boundary conditions, the distribution of temperature across the 

section as a function of time, etc. It is important to have a look at the results with a critical 

mind before proceeding to the next step, which will make use of the thermal results. 
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4. Create model for the 3D structure 

 

4.1. Modify the node line in the .TEM file 

 

As a general rule in GiD: 

 

- If you are using the “Cross-Section” option to create a profile in thermal 2D GiD-Safir 

always center the profile on the 0,0 point of the plan who is located at the middle of the 

section height as shown below. 

- If you are using the thermal TSH mode, GiD-Safir will automatically center the shell 

element node line on 0,0. 

 

As a result, currently, the nodelines of our beam (IPE550.tem) and our slab (Slab16.tsh) are 

not consistent. We have to adjust them for the structural model. 

 

 
 

 

Open the ipe550.tem file. 

On the 3rd line you can see the line “NODELINE”. The two 0.0000E+00 numbers are 

respectively the Y0 and the Z0 coordinate in meter of the global center.  

 

  
 

To displace the local center as show below, write Y0 = 0.3550E+00  

(calculated as: h/2 + e/2 = 275 mm + 80 mm = 0.355 m) 
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Save this file and use it in the subsequent structural analysis. 

 

 

4.2. Create a new project for structural 3D analysis 

 

From the pull down menu select: 

Data->Problem type->SAFIR2016->Safir_Structural_3d 
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To save the project select (or use icons on the left): 

Files->Save   or   or [Ctrl + s] 

 

Note: If Caps lock is active on your keyboard, shortcut do not work 

 

Enter a file name, e.g.: 3DMembrane 

GiD creates a directory with the name 3DMembrane.gid 

GiD creates a number of system files in this directory. 

When you start the SAFIR calculation the Safir .IN and .OUT files will be created in this 

directory. 

 

 

 

4.3. Copy-Paste the section files in the structural analysis directory 

 

GiD has created the directory 3DMembrane.gid 

 

The structural input file, which will be created in this directory, will require the information 

from the section files. Therefore, these sections files need to be located in the same directory. 

 

Copy and paste the files ‘ipe550.tem’ and ‘Slab16.tsh’ in the directory 3DMembrane.gid 

 

In the model, the peripheral beams are assumed to remain at ambient temperature (considering 

that there are sufficiently protected from the fire). We will thus create a new section, which is 

the same as ‘ipe550.tem’, but remains at ambient temperature. 

 

Create a copy of the file ‘ipe550.tem’. Rename it ‘ipe550c.tem’. 

Open the file ‘ipe550c.tem’. Change the line HOT into COLD. 

Save and close the file ‘ipe550c.tem’. 

Copy and paste the file ‘ipe550c.tem’ in the directory 3DMembrane.gid 

 

 

  



SAFIR® training session  Tutorial – 06/2018 

3D Membrane  25 

 

4.4. Create the system geometry (3D structure) 

 

The view is by default in the x-y plane. Here, the plane of the shells will be defined in the x-y 

plane, thus the view can be kept as is. 

Yet if you want to change the view: 

To change to the 3d isometric view select from the pull down menu: 

View->Rotate->isometric 

Or if you want to define a point of view by your own use: 

View->Rotate->Trackball   or [F7]   or  

 

 

Create the system lines: 

Geometry->Create->Straight Line   or  

 

Enter in the command line (at the bottom of the widows): 

0,0,0 15,0,0   and press [Enter] 

Then press [Esc] to leave 

 

  
 

To create the 3 other lines and the corresponding surfaces: 

Utilities->Copy   or [Ctrl + c] 

And fill as shown below: 
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Then click on select and select the line and press [Esc] 

 

  
 

To see nodes and beams numbers select: 

View->Label->All  
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4.5. Define constraints for the supports 

 

From the pull down menu select 

Data->Constraints 

Select Point Constraints 

Select y and z constraints and assign them to POINT 1 and press [Esc]. 

Select y and z constraints and assign them to POINT 2 and press [Esc]. 

Select x and z constraints and assign them to POINT 7 and press [Esc]. 

Select z constraint and assign them to POINT 8 and press [Esc]. 

 

In the dial box, with Draw->Colors you can display the constraints. 

Press Finish or [Esc] to leave this view mode. 
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4.6. Assign the loads 

 

From the pull down menu select 

Data->Loads 

In the dial box, select Global Shell Load and enter a Z-Pressure of -4500 N/m².  

Select the load function FLOAD to apply the load in 20 sec.  

Assign the load to all Shells. 

 

   
 

Apply to surfaces 1, 2 and 3. 
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4.7. Create Local Axes 

 

Local Axes: The orientation of the cross-section is controlled by defining a local axes X’Y’Z’ 

–system. 

 

 
 

Unlike SAFIR which needs a 4th node to describe the orientation of a cross section on a beam, 

the GiD-SAFIR interface uses a local X’Y’Z’ axes system. When you start the SAFIR calculation 

the GiD-SAFIR Interface creates the 4th node in the X’Y’ plane. If the center of the local axes 

is not located on the system line of the beam, the direction vector of the Y’-axis is used together 

with the starting point of the beam to define the 4th node. However the GiD-SAFIR interface 

will issue a warning message in the Viewoutput window of the calculation run. 

 

The objective is to create 2 local axes (LAX, LAY) as shown in the figure below. 
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From the pull down menu select: 

Data->Local Axes->Define 

 

 
 

Enter the name of the new local axe LAX 

Select 3 points XZ 

 

 
 

Select Point 3 as the local axis center. 

Select Point 4 as the point in positive x axis. 

Select Point 1 as the point in positive z axis. 

 

Repeat the operations to create the local axe LAY 

Select Point 1 as the local axis center. 

Select Point 5 as the point in positive x axis. 

Select Point 2 as the point in positive z axis. 

 

To draw local axes select: 

Data->Local Axes->Draw all 
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4.8. Define the global materials 

 

There are 4 materials: 

- The steel for the profile IPE550: STEELEC3EN 

- The material for the slab modeled in the steel thermal analysis: INSULATION 

- The concrete slab in the shell element: SILCOETC2D 

- The steel rebars in the shell element: STEELEC2EN 

 

  
 

    
 

 

Note: a description of the material SILCOETC2D is given in the following paper (for the 

mechanical behavior). Please cite this paper when using SILCOETC2D.  

Gernay, T., Millard, A., & Franssen, J. M. (2013). A multiaxial constitutive model for concrete in the 

fire situation: Theoretical formulation. International Journal of Solids and Structures, 50(22), 3659-

3673. 
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4.9. Define the properties (i.e. assign temperature files) 

 

The objective is to assign the .tem file named ipe550 and ipe550c to the system lines; as well 

as the .tsh file named Slab16.tsh to the system surfaces. 

 

 
 

From the pull down menu select: 

Data->Properties 

In the dial box change the File-Name: safir.tem to the temperature file (.TEM file) of the cross-

section, in this case ipe550c.tem. 

Change Local-Axes from -Automatic- to LAX 

Change the number of materials to 2. The considered beam section properties have 2 materials: 

one material for the profile (steel) and one for the slab (which will be replaced by a material 

with no structural properties, because the slab is modeled apart by the shell element).  

 

Assign the ipe550c.tem section to beams in 

IPE550 who have a local axe LAX (in this 

case beams 1 and 8). 
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Then, change the local axis to LAY and assign the property to beams 3, 4, 6, 7, 9 and 10. 

 

 
 

Then, change the file name to ipe550.tem. Change Local-Axes to LAX. Keep 2 materials. 

Assign to beams 2 and 5. 

 

You can draw the local axes of the beams to check the model. 

Select Draw -> All Conditions -> Include Local Axes 

 

 

 
 

Finally, select the surface (shell section property). Fill as indicated below. 

The shell section property has 2 materials. The materials are concrete from the slab and steel 

from the reinforcement bars. These are materials 3 and 4 in the global material system. 
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Assign this shell section property to the 3 surfaces. 

 

   
 

 

 

4.10. Assign the mass 

 

To define the mass for dynamic calculation, select from the pull down menu: 

Data-> Mass 

Select Mass on Beam and put 100 kg/m as Distributed-Beam-Mass and 2 as Rotational-Inertia. 

Assign to all the beam elements. 

 

     
 

Then, select Mass on Shell and put 450 kg/m². Assign the mass to all the surfaces.  
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4.11. Define the general problem data 

 

Select from the pull down menu: Data->Problem Data 

And fill as shown below 

     
 

 

4.12. Define the mesh 

 

Select Mesh -> Structured -> Surfaces -> Assign number of cells 
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Select the 3 surfaces. 

 

Assign 6 elements to lines 3, 6 and 9 (lines 4, 7 and 10 are automatically selected because the 

mesh is structured). 

Assign 24 elements to line 1 (lines 2, 5 and 8 are automatically selected).  

 

Select Mesh -> Mesh criteria -> Mesh -> Lines 

Select all the lines. Press [Esc] to validate. 

 

 
 

Select Generate Mesh and then View Mesh 
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4.13. Start the calculation 

 

From the pull down menu select: 

Calculate->Calculate window 

Click the Start button 

 

You can follow the progress of the calculation by selecting Calculate->View process info 

 

 

4.14. Check the results 

 

Open the .XML file in Diamond to check the model. Plot the support conditions, applied loads, 

deflected shape, membrane forces, etc. 
 

 

 

 

 


