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1. General description

This example deals with a cantilever beam made of an angle profile. The beam is 1 m length
and is subjected to a uniformly distributed load. The plates are 6 mm thick. The steel has a yield
strength of 275 MPa at ambient temperature. The steel beam is at uniform temperature of 600°C
and the objective is to determine the failure load P.

The beam is modeled with shell finite elements.

P [N/m?]

20cm

2. Section for the plates
2.1. Create a project in 2D for TSH thermal analysis

From the pull down menu select:
Data -> Problem type -> SAFIR2016 -> Safir_Thermal_tsh

To save the project select (or use icons on the left):
Files->Save or [Ctrl + s]

Enter a file name, e.g.: plate

GID creates a directory with the name plate.gid

GiD creates a number of system files in this directory.

When you start the SAFIR calculation the Safir . IN, .OUT and .TSH files will be created
in this directory.
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2.2. Create the geometry of the cross-section

GiD will open automatically a new window.
Put 0.006 m as shell thickness and 6 as number of elements, as shown below:

Create Shell-Section n

Shell_Thickness(t) in meter 0.006
Number_of_Elements(n) |6

Apply ‘ Close |

Click on Apply

B st Thermal tan it Progoct: UNMMAMED (SAFIRAN RS Thermal )
Files View Gecmetry Utilities Deta Mesh Calculate  About froblem Type  Halp

CUS|BRED BRI DD e SE- IR AL
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@@hpgm | Ke
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SOSRHBTBPRTALIAA

B |

l—t x
Lexvin,

ration
Deprecatod transparant syntax without ' prefie: use ‘Zoam instead Zoom

Zoom: Tx Modes: 0, Elernents: [ Render: Normal Layers: 1

Note that the section is centered with respect to the y-axis.
It means that in the structural model, the nodeline of the shell elements is located at mid-
height of the section (if no modification of the nodeline is made by the user).

2.3. Assign the thermal boundary conditions
No thermal boundary conditions will be assigned in this model. The temperatures will be

modified manually in the .tsh file later on to impose a uniform temperature of 600°C
constant over time.
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2.4. Assign the materials

From the pull down menu select: Data->Materials
Select STEEL from the dialog box pull down list. The Thermal tab is active.
Then select:
STEELEC3EN as Material Type
A Convection Coeff hot of 25
A Convection Coeff cold of 4
A Relative Emission of 0.7

Materials n
.STEEL v.@ 6 “ =l x? @

MatenalType STEELECIEN ~
Convection Coeff hot|25

Convection Coeff cold|4

Relative Emission (0.7

Assign Draw Unassign Exchange

Close

Click on Assign-> Surfaces and assign it to the surface. Press [Esc] or Finish to confirm.

Select DRAW->all materials in the Material dialog box to display Materials
Press [Esc] or Finish to leave

2.5. Assign the general data
From the pull down menu select: Data->Problem Data

In the Problem Data dialog mask enter TIMESTEP, UPTIME, TIMEPRINT as needed.
Click on the Accept data button

Problem data n
"2 3

General | Rebar-Layer-Local | Rebar-Layer-Global

Title 1|Safir_Shell_Te
Title 2| Mesh_from_G
TETA|D.9
TINITIAL|20.0
SOLVER PARDISO ~
NCORES[1
Type of calculation MAKETSH -
TIMESTEP|12
UPTIME| 1000
TIMEPRINT | 500

Accept Close
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2.6. Create the mesh

Select Mesh->Generate mesh or use [Ctrl + g]
The size of elements is irrelevant since the number of elements has been chosen in 2.2. Just
validate with OK. Click on View mesh to visualize the mesh

2.7. Start the calculation

From the pull down menu select:
Calculate->Calculate window
Click the Start button

Click the Output View button

GID creates a .IN file in the project directory and starts the calculation.

In the output window you can see the calculation progress from SAFIR and the GiD
interface program which generates GiD postprocessor files from the .OUT file.

Click on “Ok”, save, and open the postprocessor Diamond to visualize the results.

Fla=XML - [= kS
file Dt Ohspley 2ol Resulls  Optons  Wirdow  Help
i R & ™ X HiNodes Soiics (contour EMesh _
fimesens 1000~ | Eliemperatre Wechar | fLaoel[ice node a1 Nades Remave 211

Diamond 2016 for SAFIR

FILE : plate
NODES : 14
SOLIDS : 6

MESH PLOT
TEMPERATURE PLOT

TEMPERATURE :
I 20°C to 20°C
[ 20°C to 20°C
[ 120°C to 20°C
[0 20°C to 20°C
[ 20°C to 20°C
[ 20°C to 20°C
I 20°C to 20°C
I 20°C to 20°C

L.
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2.8. Modify the .tsh file

The .tsh file of this model (‘'plate.tsh’) will need to be copy-pasted in the folder with the
structural model. But first it needs to be modified. Go into the folder plate.gid and open the
file plate.tsh.

& DASAFIR\Courses_SAFIR\Formation-20180621\GiD-Examples\SAFIR-training-3-Shell_profile\plate.gid\plate.TSH - Notepad+ +

File Edit Search View Encoding Language Seitings Tools Macro Run Plugins Window 7

PR, RrlE] [l higlex BRI EIEAu®| @ ]
B tramein 3 b.'plateTSHﬂ|

Safir_shell Temperature_Analysis
Mesh_from_GID-Mesher
THICENESS 0.00€
MATERTAL 1
REBARS 0
8 HOT
9 POSITIONS OF THE NODES.
10
11 NUMEER QF POSITIONS: 7
12 —0.3000E-0Z -0.2000E-02 -0.1000E-02 0.0000E+00 0.1000E-02 O0.2000E-02 0.3000E-02
1
14 TIME= 1000.0000 SECONDS OR 16 MIN. 40 SEC.
15
16 -0.0030 20.00
17 —0.0020 20.00
18 —0.0010 20.00
1 0.0000 20.00
0.0010 20.00
0.0020 20.00
0.0030 20.00
24 TIME= 1000.0000 SECONDS OR 1€ MIN. 40 SEC.
-0.0030 20.00
=0.0020 20.00
-0.0010 20.00
0.0000 20.00
30 0.0010 20.00
31 0.0020 20.00
32 0.0030 20.00

The temperature will uniformly be increased to 600°C in 100 sec, then it will be maintained
constant. To do that, modify the file as shown below.

L‘i{ D:ASAFIR\Courses_SAFIR\Formation-20180621\GiD-Examples\SAFIR-training-3-Shell_profile\shell.gid\plate. TSH - Notepad ++
File Edit Search View Encoding Language Settings Tools Macro Run Plugins Window 7

pYEe] & 2@y 2k BRE(ST EEERE ®| @
Bfamein & Eplate TSH i:”

4 THICKNESS 0.006
5 MATERIAL 1
6 REBARS 0
7
8 HOT
S POSITIONS OF THE NODES.
NUMBER OF POSITIONS: 7
—-0.3000E-02 -0.2000E-02 -0.1000E-02Z 0.0000E+00 0.1000E-02Z O0.2000E-02 0.3000E-02
TIME= |0.0000 FECONDS OR 1lé MIN. 40 SEC.
—0.0030 20.00
—-0.0020 20.00
—-0.0010 20.00
0.0000 20.00
0.0010 20.00
0.0020 20.00
0.0030 20.00
TIME= 100.0000| SECONDS OR 16 MIN. 40 SEC.
—0.0030 €00.00
—-0.0020 €00.00
-0.0010 €00.00
0.0000 €00.00
0.0010 €00.00
0.0020 €00.00
0.0030 €00.00
TIME= 10000.0000 | SECONDS OR 16 MIN. 40 SEC.
—0.0030 €00.00
-0.0020 €00.00
—-0.0010 €00.00
0.0000 €00.00
0.0010 €00.00
0.0020 €00.00
0.0030 €00.00
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3. Create model for the 3D structure
3.1. Create a new project for structural 3D analysis

From the pull down menu select:
Data->Problem type->SAFIR2016->Safir_Structural_3d

'ﬁ Safir_Structural_3D x64 Project: UNNAMED (SAFIR2016\5afir_Structural_3d)
Files View Geometry Utilities Data Mesh Calculate Structure Help

0 © 9 | N ______'_‘e—} Problem type ansys55 » @ | @ ? | ﬂ

X i Caltep
- 9 Constraints EBxamol .
amples
y
= u Loads Fluent
o — Properties Openfoam
| E SAFIR2016 Safir_Structural_2d
?é),lj Mass 3 SAP2000 v Safir_Structural_3d
$ oroblem Dot S Safir_Thermal_2d
/" ;E.\ roplem Dete ransie m,... Safir_Thermal_3d
. Internet retrieve... .
™ @ Material Load. Safir_Thermal_tsh
_— oad...
I p Unload
Rel
3 .' % feese Debugger...
1 Local axes »
|
— a1

To save the project select (or use icons on the left):

Files->Save or © or [Ctrl + s]
Enter a file name, e.g.: shell
GID creates a directory with the name shell.gid
GID creates a number of system files in this directory.
When you start the SAFIR calculation the Safir .IN and .OUT files will be created in this
directory.
3.2. Copy-Paste the section file in the structural analysis directory

GID has created the directory shell.gid

The structural input file, which will be created in this directory, will require the information
from the section files. Therefore, these sections files need to be located in the same directory.

Copy and paste the files ‘plate.tsh” in the directory shell.gid
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3.3. Create the system geometry

To change to the 3d isometric view select from the pull down menu:
View->Rotate->isometric
Or if you want to define a point of view by your own use:

View->Rotate->Trackball or [F7] or L

Create the system lines:

s

Geometry->Create->Straight Line or -

Enter in the command line (at the bottom of the widows) successively the coordinates of
the nodes that define the lines. After typing the coordinates of a node, click [Enter] to
validate.

Leaving line creation. 0 new lines
Enter points to define line (E5C to leave)

Command: |D o0

- ]

Press [Enter]

Enter points to define line (ESC to leave)
-=000

Command: [00.150
Zoom: 0.601x

Press [Enter]

Command: [10.150
Zoom: 0.745x

Press [Enter]

Command; |'I oo
Foom: 0.745x

Press [Enter]

Comrmand: |D 0q
Zoom: 0.745x

Press [Enter] and select Join, then press [Esc].
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Create point procedure n
Click the image to get the existing peint or create a new one
No join Join
Mew point is created Existing point is selected

MOTE: Ctrl-a toggles between Join and Ne join modes,

You should see this in GiD:

Create the first surface:
Geometry->Create->Surface or M
Select the lines that define the contour of the surface.

Then, press the [Esc] key to validate. You should see this in GiD:

Proceed similarly to create the second plate. First create the system lines:

"
B!
ot

Geometry->Create->Straight Line or -
Enter in the command line:

Leaving line creation. 0 new lines
Enter points to define line (ESC to leave)

Command: |D 00

Lt

Press [Enter] and select Join
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Command: |@D 0 -D.EI
Loom: 3.2%
Press [Enter]

Command: |@1 ] [1

Zoom: Tx

Press [Enter]

Command: |@000.2
Zoom: 3.2%x
Press [Enter] and select Join, then press [Esc].
You should see this in GiD:

Then create the second surface:
Geometry->Create->Surface or M
Select the lines that define the contour of the second surface.

Then, press the [Esc] key to validate. You should see this in GiD:

To see nodes, lines and surfaces numbers select:
View->Label->All

3D Shell profile 10



SAFIR® training session Tutorial — 06/2018

3.4. Define constraints for the supports

The angle beam is fully fixed at one end.

From the pull down menu select

Data->Constraints

Select Line Constraints

Tick all the boxes.

Assign these constraints to Line 1 and Line 5 and press [Esc] or Finish to validate.

E Safir_Structural_3D &4 Froject: shell (SAFIRZ016\5afir_Structural_3d)
Files View Geometry Utilties Dats Mesh Calculate Structure  About Problem Type  Help

COSRREP BRI PD by« S| 274
F e

e
feerogo | K

3

D | Y

SERHBYBPx b P AR

z
.A ¥
Added | new lines ta the selection. Enter more ines, (ESC to leave)

Added 1 new lines to the selection. Enter more lines, (ESC to leave)

Command: |
Zoom: 132« Nodes: 0, Elernents: 0 Render: Narmal Layers: 1 (-0

In the dial box, with Draw->Colors you can display the constraints.
Press Finish or [Esc] to leave this view mode.

3.5. Assign the loads

From the pull down menu select
Data->Loads
Select Global Shell Load

Specify a distributed load of -100 N/m2 in Z direction
Use the function User Defined

As Filename, write load.fct

Assign this load on the Surface 1

Press Finish or [Esc] to validate
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Loads n
o \ |
Global Shell Load v} z? 2

X Pressure|0.0
Y Pressure|0.0
z Pressure_-'IDO,D
LOAD FUNCTION User Defined ~
Filename3.fct :Ioad.fct

Assign Entities Draw Unassign

Close

3.6. Define the global materials

From the pull down menu select

Data->Material

There is only 1 material in the model: STEELEC32D (note that it is a plane stress model)

Material

Temperatures | General | Materiall

Mumber of matenals 1 -

=]
2

Material

Temperatures |Genera| Materiall

Materiall STEELEC32D +

Mat1 E-Modulus

Mat1 Poisson ratio

Mat1 Yield strength

Mat1 Max Temperature

Mat1 Rate Decrease Yield Strength

3D Shell profile
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3.7. Define the properties (i.e. assign temperature files)

From the pull down menu select
Data->Properties

The objective is to assign the .tsh file named plate.tsh to the model surfaces.
In the dial box of Data->Properties, select the SHELL Section Property
Change the File-Name to plate.tsh

Keep the number of materials to 1

Assign the plate.tsh section to the surfaces.

— ” 5 2
SHELL Section property g 1 N2 @ ///
Shell Temp File-Name | plate.tsh 74 2
Number of shell materials 1~ - 2
Shell Mat1 Global Nr|1 o
Shell Mat2 Global Nr 2 S

Shell Mat3 Global Nr 3 // B P

Assign Entities Draw  Unassign b

Close

You can draw the properties to check the model.
Select Draw -> Colors

3.8. Assign the mass

To define the mass for dynamic calculation, select from the pull down menu:
Data-> Mass

Select Mass on Shell and put 100 kg/m? as Distributed-Shell-Mass.

Assign the mass to the two surfaces and validate.

Mass for Dynamic Calculation n
@ ’ . e

Mass on Shell v ‘ r? @
Distributed-Shell-Mass|100.0 |

Assign Entities Draw Unassign

Close
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3.9. Define the general problem data

Select from the pull down menu: Data->Problem Data
And fill as shown below

General n General n
2 2 2 3

Calculation parameters | Output optional results | Calculation parameters Output optional results |

Title 1|Safir_Static_3[ [] PRINTTMPRT Print temperatures in the fibers
Title 2| Mesh_from_G [C] PRINTVELAC Print velocity and acceleration
SOLVER PARDISO ~ [“] PRINTREACT Print reactions
NCORES‘:| ] PRINTMN Print internal forces of beams
Loads DYNAMIC APPRNR v [C] PRNEIBEAM Print stiffness in beams
C COMEBACK D PRINTSHELL Print stresses in shell elements
R ” [¥] PRNNXSHELL Print membrane forces in shell element:
TIMESTEPMIN PPRNMXSHELL Print bending moments in shell elemen

[[] Consider max displacement

PRECISION
NGEOBEAM
NG
NFIBEREEAM
NGEOTRUSS
NGEOSHELL
NGSHELLTHICK
NREBARS
TIMESTEP
UPTIME
TIMESTEPMAX
TIMEPRINT

1.0e-3

0
2
440
0
1
9
0

10
10000
100

el

[] PRNEASHELL Print membrane stiffness in shell elemer
[C] PRNEISHELL Print Bending stiffness in shell elements
] PRNSTRAIN Print strains and stresses in shell elements

Accept Close _ Accept Close

3.10. Define the mesh

Select Mesh -> Structured -> Surfaces -> Assign number of cells

B safir_Structural 3D x64 Project: shell (SAFIR2016\Safir_Structural_3d)
Files View Geometry Utiities Data  Mesh Calculate Structure AboutProblem Type Help

e
OO LR ED € vt Cl | 2
S Structured Lines »
»e tured » |1 Surfaces Assign number of cells
& F Cartesian Ll < b Assignsize )
2 ; Boundary layer » Center structured - e
a A .
T e Quadratic type » [ St 720 2
0 a8 Element type » > } -
Pt Mesh criteria » y -
- Reset mesh data A
\ = Draw » //
B < Generate mesh... Ciri-g s
S o e
~ d Edit mesh » //
E ! P .
/-,/ 2 7
/ Z
Mesh options from model " 7

L]
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Select the two surfaces, for which a structured mesh will be applied. Press [Esc] to validate.

Enter 10 as the number of cells to assign to lines. Select the lines 2, 4 and 6 (1 m long lines).
Press [Esc] to validate.

Enter value window n

0 Enter number of cells to assign to
lines

10

Assign Close

Then enter 4 as another number of cells to assign to lines.

Enter value window n

Enter another number of cells to
assign to lines

b ]

Assign Close

Select the lines 1, 3, 5 and 7 (short lines). Press [Esc] to validate.

4
1

Click on Close.

Next, it must be specified that the lines in the model need not be meshed as beam finite
elements.

Select Mesh -> Mesh criteria -> No mesh -> Lines

Select all the lines in the model. Press [Esc] to validate.
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Safir_Structural_3D x84
Files View Geometry Utilities Data

PR BBRD |
o

Mesh  Calculate  Structure  Help

Unstructured
Structured

Cartesian

- vy v ¥

Boundary layer

Quadratic type
Element type
Mesh criteria
Reset mesh data

Draw

Project: UNMNAMED (SAFIR2071645afir_Structural_3d)

o

# Generate mesh...

Edit mesh

Ctrl-g

Automatic skip L4
Skip by...

Force peints to L4

Mesh options from model

Duplicate 4
Mo Duplicate L4

Select Generate Mesh, OK and then View Mesh

3.11.

Create the loading file

US| 22 ¥
Default L4
Mesh 4
Ma mesh 2 Points
Default mesh H® . Lines K
Skip N '1’7 Surfaces
No skip [ i

In this model a user-defined load function was used, named load.fct (see 3.5). This file
needs to be created and located in the directory shell.gid.

The text file load.fct can be edited in a text editor. It is structured as shown below, where
the first column is the time (in sec) and the second column is the load (in N). You can define
as many time-load pairs as needed. SAFIR will interpolate linearly between the given

values.

Here, it is decided to keep the load to zero while the structure is heated (from 0 to 100 sec)
then to increase the load linearly as time/10.

3D Shell profile
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Note that here this function will be multiplied by -100 N/m? as defined in Section 3.5. As a
result, we increase the load by 1 kN/m? every 100 sec in the vertical direction pointing
downwards, starting after 100 sec.

J load fct - Bloc-notes — | ped

IFichier Edition Format Affichage ?
(%] a.
160. a.
1100. [00.
10100 10086.

3.12. Start the calculation
From the pull down menu select: Calculate->Calculate window

Click the Start button

You can follow the progress of the calculation by clicking on Output view or by selecting
Calculate->View process info

3.13. Check the results

Open the . XML file in Diamond to check the model.

Here below is the result with a finer mesh (not suitable for the demonstration version).
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