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1. General description 

 

This example deals with a 3D frame structure of 8 m by 8 m by 4 m. The columns are reinforced 

concrete section of 30 cm x 30 cm, with 4 φ20 steel bars with an axis cover of 30mm, heated 

on 3 faces. The beams are IPE 300 steel profiles, heated on 3 faces. The columns are fixed, 

while the beams are pinned. The beams are subjected to uniformly distributed loads of 10 kN/m. 

Steel for IPE300: yield strength 355 MPa 

Steel for reinforcement bars: yield strength 500 MPa 

Concrete: compressive strength 30 MPa; tensile strength 1 MPa 

 

2. Section for IPE300 steel beam 

 

The model created in a previous exercise will be used here. 

 

 
 

The .tem file of this model (’ipe300.tem’) will need to be copy-pasted in the folder with 

the structural model. 

 

3. Section for concrete column 

 

The model created in a previous exercise will be used here. 

 
The .tem file of this model (’rc30x30.tem’) will need to be copy-pasted in the folder with 

the structural model.  
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4. Create model for the 3D structure 

 

4.1. Create a new project for structural 3D analysis 

 

From the pull down menu select: 

Data->Problem type->SAFIR2016->Safir_Structural_3d 

 

  

 

To save the project select (or use icons on the left): 

Files->Save   or   or [Ctrl + s] 

 

Note: If Caps lock is active on your keyboard, shortcut do not work 

 

Enter a file name, e.g.: 3DBuild 

GiD creates a directory with the name 3DBuild.gid 

GiD creates a number of system files in this directory. 

When you start the SAFIR calculation the Safir .IN and .OUT files will be created in this 

directory. 

 

 

4.2. Copy-Paste the section files in the structural analysis directory 

 

GiD has created the directory 3DFrame.gid 

 

The structural input file, which will be created in this directory, will require the information 

from the section files. Therefore, these sections files need to be located in the same directory. 

 

Copy and paste the files ‘ipe300.tem’ and ’rc30x30.tem’ in the directory 3DFrame.gid 
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4.3. Create the system geometry (3D structure) 

 

The view is by default in the x-y plane. Here, the plane of the frame will be defined in the  

x-z plane. 

To change to the 3d isometric view select from the pull down menu: 

View->Rotate->isometric 

Or if you want to define a point of view by your own use: 

View->Rotate->Trackball   or [F7]   or  

 

Create the system lines: 

Geometry->Create->Straight Line   or  

 

Enter in the command line (at the bottom of the widows) successively the coordinates of 

the 5 nodes that define the first frame in the command box. After typing the coordinates 

of a node, click [Enter] to validate. 

 

 
Press [Enter] 

 

 
Press [Enter] 

 

 
Press [Enter] 

 

 
Press [Enter] 

 

 
Press [Enter] 

 

Then press [Esc] to leave the line creation menu. 

 

You should see this in GiD: 
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To create the 2 other frames: 

Utilities->Copy   or [Ctrl + c] 

And fill as shown below: 

 
 

Then click on select and select the line and press [Esc] 

 

To see nodes and beams numbers select: 

View->Label->All  
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Finally, create the last system lines: 

Geometry->Create->Straight Line   or  

 

Press Ctrl + A to switch the pointer to the mode: ‘pick an existing point’. 

Click on Node 2, then Node 7, then Node 12. Press [Esc].  

Repeat with Node 3, then Node 8, then Node 13. Press [Esc]. 

Repeat with Node 4, then Node 9, then Node 14. Press [Esc]. 

(Note: do not forget to press Ctrl + A, otherwise the line would not be connected to the 

nodes although it might look like it goes through the nodes). 
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4.4. Define constraints for the supports 

 

From the pull down menu select 

Data->Constraints 

Select Point Constraints 

Tick all the boxes for a fully fixed condition. Assign these constraints to POINT 1, 

POINT 5, POINT 6, POINT 10, POINT 11, POINT 15, and press [Esc]. 

 

  
 

In the dial box, with Draw->Colors you can display the constraints. 

Press Finish or [Esc] to leave this view mode. 

 

  



SAFIR® training session  Tutorial – 01/2019 

3D Frame  8 

 

4.5. Assign the loads 

 

From the pull down menu select 

Data->Loads 

 

Assign a distributed load of -10 000 N/m in Z direction on the beams, using the load function 

FLOAD. Press Finish or [Esc] to validate. 
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4.6. Create Local Axes 

 

Local Axes: The orientation of the cross-section is controlled by defining a local axes X’Y’Z’ 

–system. 

 

 
 

Unlike SAFIR which needs a 4th node to describe the orientation of a cross section on a beam, 

the GiD-SAFIR interface uses a local X’Y’Z’ axes system. When you start the SAFIR calculation 

the GiD-SAFIR Interface creates the 4th node in the X’Y’ plane. If the center of the local axes 

is not located on the system line of the beam, the direction vector of the Y’-axis is used together 

with the starting point of the beam to define the 4th node. However the GiD-SAFIR interface 

will issue a warning message in the Viewoutput window of the calculation run. 

 

The objective is to create 5 local axes (LAXU, LAXD, LAY, LAZU, LAZD) as shown in the 

figure below. 
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From the pull down menu select: 

Data->Local Axes->Define 

 

Enter the name of the new local axe LAZD 

Select 3 points XZ 

 

 
 

Select Point 2 as the local axis center. Note: Press “CLTR + A” to allow the selection of an 

existing point with the mouse. 

Select Point 1 as the point in positive x axis. 

Select Point 7 as the third node points to the positive direction along the z axis.  

Press Enter 

You should see this in GiD. This local axis LAZD will be used for Columns 1, 5 and 9. 

 

  

 

Repeat the operations to create the local axe LAZU 

Select Point 5 as the local axis center. 

Select Point 4 as the point in positive x axis. 

Select Point 10 as the point in positive z axis. 

Press Enter 

This local axis LAZU will be used for Columns 4, 8, 12. 

 

 



SAFIR® training session  Tutorial – 01/2019 

3D Frame  11 

 

Repeat the operations to create the local axe LAY 

Select Point 7 as the local axis center. 

Select Point 12 as the point in positive x axis. 

Select Point 9 as the point in positive z axis. 

Press Enter 

This local axis LAY will be used for Beams 13, 14, 15, 16, 17, 18. 

 

 
 

 

 

From the pull down menu select: 

Data->Local Axes->Define 

Enter the name of the new local axe LAXU 

Select X and Angle 

 

Select Point 2 as the local axis center. Note: Press “CLTR + A” to allow the selection of an 

existing point with the mouse. 

Select Point 3 as the point in positive x axis. 

Enter 90 in the command box as the angle.  

Press Enter 
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From the pull down menu select: 

Data->Local Axes->Define 

Enter the name of the new local axe LAXD 

Select X and Angle 

 

Select Point 3 as the local axis center. 

Select Point 4 as the point in positive x axis. 

Enter 90 in the command box as the angle.  

Press Enter 

 

To draw local axes select: 

Data->Local Axes->Draw all 
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4.7. Define the global materials 

 

From the pull down menu select 

Data->Material 

 

There are 3 materials in the model: 

- The steel for the profile IPE300: STEELEC3EN 

- The steel for the reinforcement of the concrete columns: STEELEC2EN 

- The concrete for the columns: SILCON_ETC 

 

In the section IPE300:  MAT 1 = STEELEC3EN 

In the section RC30x30:  MAT 1 = STEELEC2EN, MAT 2 = SILCON_ETC 

 

  
 

In the structural model, we decide that the order is: 

MAT 1 = STEELEC3EN 

MAT 2 = STEELEC2EN 

MAT 3 = SILCON_ETC 
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Note: a description of the material SILCON_ETC is given in the following paper:  

Gernay, T., & Franssen, J. M. (2012). A formulation of the Eurocode 2 concrete model at 

elevated temperature that includes an explicit term for transient creep. Fire Safety Journal, 51, 

1-9.  
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4.8. Define the properties (i.e. assign temperature files) 

 

From the pull down menu select 

Data->Properties 

 

The objective is to assign the .tem file named ipe300 and rc30x30 to the model lines. 

 

 
 

In the dial box of Data->Properties, change the File-Name: safir.tem to the temperature 

file (.TEM file) of the cross-section, in this case ipe300.tem. 

 

Change Local-Axes from -Automatic- to LAXU 

Keep the number of materials to 1. The Mat1 Global Nr is 1 (it is the STEELEC3EN).  

Assign the ipe300.tem section to the beams 2, 6 and 10. 
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Then, keep the file name to ipe300.tem but change Local-Axes to LAXD. Keep 1 material with 

the Mat1 Global Nr equal to 1. 

Assign to the beams 3, 7 and 11. 

 

    
 

 

Then, keep the file name to ipe300.tem but change Local-Axes to LAY. Keep 1 material with 

the Mat1 Global Nr equal to 1. 

Assign to the beams 13, 14, 15, 16, 17, 18. 
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Then, change the file name to rc30x30.tem. Change Local-Axes to LAZU. Specify 2 materials. 

The Mat1 Global Nr is 2 (it is STEELEC2EN). The Mat2 Global Nr is 3 (SILCON_ETC). 

Assign to columns 4, 8, 12. 

 

    
 

Finally, keep the file name to rc30x30.tem but change Local-Axes to LAZD. Keep 2 materials 

with Mat1 Global Nr is 2 and Mat2 Global Nr is 3. Assign to columns 1, 5 and 9. 

 

   
 

 

You can draw the local axes of the beams to check the model. 

Select Draw -> All Conditions -> Include Local Axes 
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4.9. Assign the RELAX conditions 

 

From the pull down menu select 

Data->Relaxations 

 

The objective is to assign pinned conditions at the end of all the beams in the model (i.e. no 

transfer of strong axis bending moment between the beams and the columns). 

 

Before (without relaxations) After (with relaxations) 

  
 

After selecting Data->Relaxations, this window appears: 

 
 

For each Beam, the user can apply Relaxations conditions to either extremity (Node1 or 

Node2), according to any of the 7 degree of freedom at this end node. 

 

The degrees of freedom are to be considered in Local Axes coordinates! 

 

To identify Node1 from Node2, arrows are drawn on the beam elements of the structure, as 

indicated on the picture in the window here above. 
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Assign a value of “0” to N1 DOF6 and assign to Beams 2, 6 and 10.  

Press Finish or [Esc] to validate. 

 

 
 

Assign a value of “0” to N2 DOF6 and assign to Beams 3, 7 and 11.  

Press Finish or [Esc] to validate. 

 
 

Assign a value of “0” to both N1 and N2 DOF6. Assign to Beams 13, 14, 15, 16, 17, 18.  

Press Finish or [Esc] to validate. 
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You can draw the Relaxations to check the model. 

Select Draw -> Colors 

 

 
 

 

 

 

 

 

4.10. Assign the mass 

 

To define the mass for dynamic calculation, select from the pull down menu: 

Data-> Mass 

Select Mass on Beam and put 100 kg/m as Distributed-Beam-Mass and 2 as Rotational-

Inertia. Assign to all the beam elements. 
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4.11. Define the general problem data 

 

Select from the pull down menu: Data->Problem Data 

And fill as shown below 

   
 

 

4.12. Define the mesh 

 

Select Mesh -> Structured -> Lines -> Assign number of cells 
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Assign 10 elements. Select all the lines. Press [Esc] to validate. 

 

 
  

Select Generate Mesh and then View Mesh 

 

 
  



SAFIR® training session  Tutorial – 01/2019 

3D Frame  23 

4.13. Start the calculation 

 

From the pull down menu select: 

Calculate->Calculate window 

Click the Start button 

 

You can follow the progress of the calculation by selecting Calculate->View process info 

 

 

4.14. Check the results 

 

Open the .XML file in Diamond to check the model. Plot the support conditions, applied loads, 

deflected shape, membrane forces, etc. 

         
 

 

 


