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1. General description 

 

This example deals with a steel beam exposed to fire on its lower face. The beam will be 

modeled using 3D solid finite elements.  

 

General data: 

- Simply supported beam with 6 m span 

- Steel profile HEB 400 

- Yield strength 355 MPa 

- Fire: ISO fire on the lower face 

- Loads: point load applied at mid-span 

 

 

 
 

 

The dimensions of the HEB 400 section are as follows: 

- Width    300 mm 

- Height   400 mm 

- Web thickness  13.5 mm 

- Flange thickness  24 mm 
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2. Thermal Model 

 

The objective is to create the 3D geometry of the beam and to analyze it under fire exposure. 

The same geometry and discretization will be used for the subsequent 3D structural analysis. 

 

2.1. Create a project in 3D for Thermal Analysis 

 

From the pull down menu select: 

Data -> Problem type -> SAFIR -> Safir_Thermal_3d 

 

 
 

To save the project select (or use icons on the left): 

Files->Save or or [Ctrl + s] 

 

Enter a file name, e.g.: 3Dtherm_steel 

GiD creates a directory with the name 3Dtherm_steel.gid 

GiD creates a number of system files in this directory. 

When you start the SAFIR calculation the Safir .IN and .OUT files will be created in this 

directory. 

Note: the 3Dtherm_steel.OUT file will be needed for the 3D structural model. 

 

 

2.2. Create the geometry of the beam 

 

We will create the beam with the following coordinate convention: 

- Length along the global x-axis 

- Cross-section in the y-z plane with the height along the global z-axis 

 

The view is by default in the x-y plane.  

We will start by drawing the cross-section. To switch the view to the y-z plane, select: 

View->Rotate->Plane YZ 

 

Important note: 3D solid elements in SAFIR are hexahedra (version 2019 and earlier). 

To mesh with tetrahedral in GiD, a Structured Volume mesh should be specified. To ensure 

that such mesh condition can be applied to the volumes, it is recommended to define a 

regular structure based on parallelepiped volumes. 
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We will first create the geometry of the cross-section in the YZ plane, centered at (0,0,0), 

using Lines and NURBS surfaces. 

 

Select the create line command. 

           or              

 

We start by defining the left half of the lower flange. The first point defining the lines is: 

0   -0.150   -0.200 

Type these coordinates in the command box, then validate with enter. 

 
 

Next, type the coordinates: 

0   -0.00675   -0.200 

0    0.             -0.200 

0    0.             -0.176 

0   -0.00675   -0.176 

0   -0.150       -0.176 

0   -0.150       -0.200 

When validating the latter, press Join to close the rectangle (if prompted). 

 

Press [Esc] then select again the create line command. 

Press Ctrl+A to switch the mouse mode to Pick an existing point. Pick the points (0,-

0.00675, -0.200) then (0,-0.00675, -0.176) to draw a line between these two. 

At the end, it should look like that (left half of lower flange): 

 

 
Note: if two points with the same coordinates were created, use the command   

Geometry->Edit->Collapse->Model 
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This command will merge points or lines which are on top of each other (the command box 

will indicate if nodes have been deleted). 

 

 
 

Next, create 2 NURBS surfaces for the 2 rectangles. 

 

We will now duplicate these surfaces to create the right half of the lower flange. 

Select Utilities->Copy 

and apply a mirror transformation to the surfaces as shown below. The plane defining the 

mirror is the plane XZ (1st point 0,0,0; 2nd point 1,0,0; 3rd point 0,0,1): 

 
 

Select the 2 surfaces and press Finish. This resulted in the creation of the right half of the 

lower flange. 

Now, we can apply the same technique to copy the 4 surfaces of the lower flange to create 

the upper flange.  

Select Utilities->Copy 
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and apply a mirror transformation to the 4 surfaces where the plane defining the mirror is 

the plane XY (1st point 0,0,0; 2nd point 1,0,0; 3rd point 0,1,0). 

Select the 4 surfaces and press Finish. This resulted in the creation of the upper flange. 

 

 
 

Next, we will create the web.  

Select the create line command. Press Ctrl+A to switch the mouse mode to Pick an existing 

point. Pick the points defining the web and join them by lines. Then, create the 2 NURBS 

surfaces for the left and right part of the web. 

 

Note: if a NURBS surface fails to be generated (with the command box indicating a message 

such as “error, bad surface, contour lines not closed”), the most likely reason is that there 

are several nodes at the same coordinates. This can be solved again using the command: 

Geometry->Edit->Collapse->Model 

 

The cross-section is now complete. 
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Now, we will extrude this cross section along the length of the profile. 

Change to the 3d isometric view by selecting from the pull down menu: 

View->Rotate->isometric 

 

Go into the Copy functionality:  

Utilities->Copy 

And apply translation to the surfaces, with Do extrude: Volume, as shown below.  

Note that we proceed in two steps of 3 m along x in order to have a point defined at mid-

span. Therefore, we apply the transformation twice (multiple copies: 2). 

Select all surfaces and click on Finish. 

 

 
 

The geometry of the 6 m long steel beam is now completed. 
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2.3. Assign the thermal conditions 

 

In GiD, from the pull down menu select: 

Data->Conditions 

 

Note: With 3D solid thermal analyses, frontier constraints are applied on surfaces. 

 

The ISO fire is selected by default. 

Click on the Assign button and assign the fire on the lower face (8 surfaces in total). 

Press [Esc] or click on Finish to confirm 

 

Next, select F20 as temperature curve 

And assign it to the web and upper flange external faces. Press [Esc] to confirm. 

 

 
 

 

2.4. Assign the materials 

 

From the pull down menu select: 

Data->Materials 

 

STEEL is selected by default in the dialog box pull down list 

The Thermal tab is active. Leave the parameters as they are by default, with STEELEC3EN 

as the material type. 

Click on Assign-> VOLUMES and assign it to all volumes (there should be 20 volumes). 

Press [Esc] or Finish to confirm 
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2.5. Assign the general data 

 

From the pull down menu select: 

Data->Problem Data 

 

In the Problem Data dialog mask enter: TIMESTEP, UPTIME, TIMEPRINT as needed 

In particular, change the UPTIME to 1200 sec 

 

 
 

Click on the Accept data button 

 

 

2.6. Create the mesh 

 

We want to use hexahedra as the FE type. This requires structuring the mesh. 

Select Mesh->Structured->Volumes->Assign number of cells 

 

 
 

Select all volumes in the model, press [Esc] to validate. This prompts a dialog box which 

requires to Enter number of cells to assign to lines. 

Type 40 as the number of cells to assign to lines 

Select the lines along the length of the beam (parallel to the x global axis) 

Press [Esc] to validate 

The text in the command box indicates: Assigned 40 number of cells to 40 lines 
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Next, switch the view back to the YZ plane. 

Assign 2 as the number of cells to assign to the thickness of the flanges, 4 to the half flange 

width, 1 to each half-web width, 8 to the web height. 

 

Finally, select Mesh->Element type->Hexahedra 

Apply to all volumes (select all volumes and press [Esc] to validate) 

 

 
 

Select Mesh->Generate mesh or use [Ctrl + g] 

The size of elements to be generated is irrelevant since a structured mesh has been defined 

with specified number of element. 

Validate with OK 

 

 
 

Click on View mesh to visualize the mesh 
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2.7. Start the calculation 

 

From the pull down menu select: 

Calculate->Calculate window 

Click the Start button 

(Or select directly Calculate->Calculate) 

 

Select Calculate->View process info to follow the step-by-step calculation 

 

GiD creates a .IN file in the project directory and starts the calculation. 

 

2.8. Check the results 

 

Once the calculation is done, you can open the .XML file with DIAMOND. 
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3. Structural model  

 

When using 3D solid FE, the geometry and mesh is the same in the structural model as in 

the thermal model. 

As a result, the easiest way to work on the structural model is to start from the GiD model 

of the thermal model. 

 

3.1. Translate the existing thermal project into a new project for structural 3D 

analysis 

 

Starting from the thermal model 3Dtherm_steel.gid opened in GiD: 

  Save the project in its current location 

  Then, save it as a new project: 

    Files->Save as 

    Enter a file name, e.g.: 3Dstruc_steel 

    GiD creates a directory with the name 3Dstruc_steel.gid 

  

From the pull down menu select: 

Data->Problem type->SAFIR->Safir_Structural_3d 

 

A dialog box open. Select Update to new problemtype  

 

  
 

 

3.2. Copy-Paste the thermal file .OUT in the structural analysis directory 

 

GiD has created the directory 3Dstruc_steel.gid 

The structural input file, which will be created in this directory, will require the information 

from the thermal output file (which contains the temperatures). Therefore, thermal .OUT 

needs to be copy-pasted in the 3Dstruc_steel.gid directory. 

 

Copy and paste the files 3Dtherm_steel.out in the directory 3Dstruc_steel.gid  
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3.3. Define constraints for the supports 

 

From the pull down menu select 

Mesh->Erase mesh 

To come back to the model without mesh, for defining the properties 

 

The beam is simply supported 

From the pull down menu select 

Data->Constraints 

Select Line Constraints 

Select Z-Constraint and assign to the lower flange lines at the two ends of the beam. Press [Esc]. 

 

 
 

Select Y-Constraint and assign to the section center (vertical) lines at the two ends of the beam. 

Press [Esc]. 

 

In addition, the DoF x should be blocked somewhere in the model. 

Select Point Constraint 

Select X-Constraint and assign to the lower center point of the section at the x=0 end of the 

beam. Press [Esc]. 
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In the dial box, with Draw->Colors you can display the constraints. 

Press Finish or [Esc] to leave this view mode. 

 

 
 

 

 

 

3.4. Assign the loads 

 

From the pull down menu select 

Data->Loads 

In the dial box, select Point Load and enter a Z-Force of -150000 N.  

Select the load function FLOAD to apply the load in 20 sec.  

Assign the load to the top center node at mid-span. 
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3.5. Define the global materials 

 

From the pull down menu select: 

Data->Material 

 

In the Temperatures tab is where the thermal .out file is associated to the structural model. 

In the dialog box, type the name of the Solid Temp File: 3Dtherm_steel.out 

 

 
Next go into the General tab. 

There is only 1 material. 

 

Finally, go into the Material1 tab. 

Select STEELEC33D as the material model. Change e yield strength to 355 MPa. Click Accept. 

Note: it is required to assign a tridimensional material model when using solid FE. The use of 

a uniaxial material model (e.g. STEELEC3) with a shell or a solid FE leads to immediate 

termination of the computation, this is a common source of error in the inputs. 
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3.6. Define the properties (i.e. assign temperature files) 

 

From the pull down menu select: 

Data->Properties 

In the dial box, select the volume icon to assign SOLID Section Property. 

There is only 1 material in the model, so the Solid Mat Global Nr stays at 1. 

Assign to all volumes in the model. 

 

 
 

 

3.7. Define the general problem data 

 

Select from the pull down menu: Data->Problem Data 

And fill as shown below. Notably, change NGEOBEAM to 0. Click Accept. 

 

      



SAFIR® training session  Tutorial – 06/2019 

3D Solid  17 

 

3.8. Define the mesh 

 

Select Mesh -> Generate Mesh and validate (OK). The mesh size is irrelevant since the 

structured mesh has previously been specified. 

Select View Mesh 

 

Note: the structured mesh information should have been kept from the thermal model. If it is 

not the case, repeat the procedure of Section 2.6. Eventually, the mesh needs to be the same as 

in the thermal model. 

 

 

3.9. Start the calculation 

 

From the pull down menu select: 

Calculate->Calculate window 

Click the Start button 

 

You can follow the progress of the calculation by selecting Calculate->View process info 

 

 

3.10. Check the results 

 

Open the .XML file in Diamond to check the model. Plot the support conditions, applied loads, 

deflected shape, membrane forces, etc. 

 
 

 

 


