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1. General description 

 

This example deals with the thermal analysis of a protected steel cross-section. 

 

The thermal analysis is completed in SAFIR®. The input file for the analysis is prepared using 

the GUI preprocessor GmSAFIR. 

 

General data: 

- Section W12x120 

- Protected with 11 mm thickness of Sprayed Fire Resistive Material (SFRM) 

- Steel material model according to Eurocode EN1993-1-2 

- Section exposed to ASTM E119 fire on 3 sides 

- Section in contact with atmosphere at 20°C on the side external to the fire compartment 
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2. Create a project in GmSAFIR 

 

Start GmSAFIR. Select: 

File -> New  

Select the existing folder in which you will locate your project files.  

Type the name of the project, e.g., ThermalSteel. 

Select Save 

A window appears asking if you want to continue as-is. Select Use ‘.geo. extension 

A window appears asking which geometry kernel you want to use. Select Open CASCADE 

 

 
 

We have now created a project in GmSAFIR. In the selected folder, a file ThermalSteel.geo 

was created. 

 

To build the model in GmSAFIR, we will follow a 3-steps procedure: 

▪ Create the geometry 

▪ Assign the SAFIR-specific properties (e.g., materials, fire curves, …) 

▪ Build the mesh 

After this procedure, we will use the command Create .IN file to generate an input file for 

SAFIR, which will be located in the same folder as the .geo file. 
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3. Create Geometry 

 

The cross-section is a W12x120. 

Dimensions are: 

▪ d = 332 mm (13.1 in) 

▪ bf = 312 mm (12.3 in) 

▪ tf = 28.2 mm (1.11 in) 

▪ tw = 18.0 mm (0.71 in) 

▪ k = 43.2 mm (1.70 in) 

 

The thickness of thermal insulation is 11 mm (7/16 in). 

 

We will create ¼ of the section and use symmetry. We will use translation to add the SFRM. 

 

3.1. Create Points 

 

In GmSAFIR, select Modules -> Geometry -> Elementary entities -> Add -> Point 

Type the coordinates of the points in meters. Select Add after typing each point. 

▪ 1st point: (0.009, 0, 0)     (tw/2, 0, 0) 

▪ 2nd point: (0.009, 0.1228, 0)    (tw/2, d/2 – k, 0)  

▪ 3rd point: (0.024, 0.1228, 0)  (tw/2 + k – tf, d/2 – k, 0) 

▪ 4th point: (0.024, 0.1378, 0)  (tw/2 + k – tf, d/2 – tf, 0) 

▪ 5th point: (0.156, 0.1378, 0)  (bf/2, d/2 – tf, 0) 

▪ 6th point: (0.156, 0.166, 0)  (bf/2, d/2, 0) 

▪ 7th point (0.000, 0.166, 0)  (0, d/2, 0) 

 

 
 

When done, type q to abort.  
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These points will be used to create the upper right corner of the steel section. 

 

Double click on the window and select All geometry options (alternatively: Tools -> Options 

in the menu at the top). Tick the box to show Point Labels. 

   
 

Now, we will create the points used to define the SFRM. We will use translations. 

In GmSAFIR, select Modules -> Geometry -> Elementary entities -> Transform -> Translate 

Apply the translation: 

DX 0.011, DY 0, DZ 0 

Tick the box ‘Apply Translation on Copy’ 

Select Point 1. Type ‘e’.  

A new node is created from ea translation of Points by 11 mm in the X direction. 
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Apply the translation: DX 0.011, DY -0.011, DZ 0. Tick the box ‘Apply Translation on Copy’ 

Select Point 2, Point 3, Point 4 and Point 5. Type ‘e’. 4 new nodes are created. 

 

Apply the translation: DX 0.011, DY 0.011, DZ 0. Tick the box ‘Apply Translation on Copy’ 

Select Point 6. Type ‘e’. 1 new node is created. 

 

Apply the translation: DX 0., DY 0.011, DZ 0. Tick the box ‘Apply Translation on Copy’ 

Select Point 7. Type ‘e’. 1 new node is created. 

 

When done, type q to abort.  

 

These new points will be used to create the SFRM layer on the upper right corner of the steel 

section. 

 

3.2. Create Lines 

 

In GmSAFIR, select Modules -> Geometry -> Elementary entities -> Add -> Line 

Select start point of the line. 

 

Select Point 1 as start point. Select Point 2 as end point. A line was created joining Points 1-2. 

 

Repeat with Points 4 and 5. Then Points 5 and 6. Then Points 6 and 7. Press q to abort. 

 

 

Lines must be defined such that, going from the first point to the second point defining 

the line, the surface bounded by the line is located on the left side of the line. Lines must 

therefore be defined by turning counterclockwise around the surface. 
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Now, we will create the root fillet. 

In GmSAFIR, select Modules -> Geometry -> Elementary entities -> Add -> Circle arc 

Select start point: Point 2. Select center point: Point 3. Select end point: Point 4. 

The root fillet of the steel section has been created. Type q to abort. 

 

 
 

We repeat the procedure for line creation and circle arc creation for the SFRM. 

Starting with the lines. Select Modules -> Geometry -> Elementary entities -> Add -> Line 

We create a line from Point 8 to 9, from Point 11 to Point 12, from 12 to 13, from 13 to 14. 

Type q to abort. 

Then we select Modules -> Geometry -> Elementary entities -> Add -> Circle arc 

We select Point 9, 10, and 11 to create the SFRM layer on the root fillet. Press q. 
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3.3. Use Symmetry 

 

In GmSAFIR, select Modules -> Geometry -> Elementary entities -> Transform -> Symmetry 

 

The X direction corresponds to Plane A. 

Type ‘1’ for Plane A. ‘0’ for Planes B, C, D. 

Tick the box ‘Apply Translation on Copy’ 

Select ‘Curves’ for the selection mode 

 

To select all the points and lines, press ‘ctrl’ + left click on one corner, drag the mouse to the 

other corner, then again ‘ctrl’ + left click. Everything should be selected. Then type ‘e’. 
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We now have half of the section. However, the Symmetry action has resulted in duplication of 

nodes. It is observed by showing node labels. To address this, there is a specific command in 

GmSAFIR to ‘merge’ duplicated entities. 

 

In GmSAFIR, select Modules -> Geometry -> Elementary entities -> Boolean -> Coherence 

 

Then, select Reload script 

 

This has the effect of merging the duplicated points. It is verified through the node labels. 
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Now, we apply a symmetry about the Y-axis (Plane B) to create the bottom half of the section. 

 

In GmSAFIR, select Modules -> Geometry -> Elementary entities -> Transform -> Symmetry 

 

Type ‘0’ for Plane A, ‘1’ for Plane B, ‘0’ for Plane C, ‘0’ for Plane D. 

Tick the box ‘Apply Translation on Copy’. Select ‘Curves’ for the selection mode 

Select everything. Type ‘e’ to end selection. The symmetry is applied and the bottom half of 

the section appears.  

Close the symmetry window and type ‘q’. 

 

Then, select Modules -> Geometry -> Elementary entities -> Boolean -> Coherence 

 

Then, select Reload script 

 

This has the effect of merging the duplicated points. Show the node labels to check that nodes 

are not in duplicate. 

 

 
 

 

  



SAFIR® training session  Tutorial – 04/2022 

© Thomas Gernay 2D Thermal steel beam 11 

3.4. Create Surfaces 

 

The first line that is selected must be oriented in the appropriate direction, i.e., with the surface 

on its left (counterclockwise rotation). It is possible to draw the line directions. 

Select Tools -> Options in the menu at the top. 

Type a value in the right box Normals and tangents (or click in the box and drag to the right) 

to make the line directions appear. 

Now, when creating the surface, we can select as the first line of the surface a line which would 

rotate in a counterclockwise direction around the surface. 

 

 
 

In GmSAFIR, select Modules -> Geometry -> Elementary entities -> Add -> Plane surface 

 

Starting with the steel section, select for example Line 4. 

GmSAFIR automatically selects the other boundaries of the surface because, in this case, there 

is only one possible surface bounded by that line (using the counterclockwise rule). 

Press ‘e’. The surface was created. 
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Now for the SFRM, select Line 9 at the top right. The external boundary is selected 

automatically, but the lines that form the interior boundary must also be selected. Select Line 17 

of the top left flange to satisfy the counterclockwise rule for the interior boundary of the SFRM 

surface. 

Press ‘e’. The surface was created. Press ‘q’ to abort. 

 

 
 

Surface labels can be visualized in All geometry options. The two surface labels lie on top of 

each other, but it can be checked that two surfaces have been created. 

 

This concludes the creation of the geometry.  
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4. Assign Properties 

 

In this step, we will define the properties of the model and the inputs necessary for the SAFIR 

calculation. We will use physical groups to assign the properties of the model to the lines and 

surfaces. 

. 

4.1. Define the SAFIR General Input Data 

 

In GmSAFIR, select Modules -> Solver -> SAFIR -> General 

 

Here we can define the inputs of the SAFIR calculation. 

Set the Problem Type to Thermal 2D 

Set the UPTIMEPRINT to 7200 sec 

Set the Name of the .IN File as ThermalSteel.IN 

Set the TIMESTEPMIN to 0.01 sec 

Set the UPTIME to 7200 sec and the TIMESTEPMAX to 128 sec 

 

The Type of calculation gives different options for interfacing a fire with the thermal analysis. 

Here, we will use a time-temperature curve, but it is also possible to use localized fires and 

CFD outputs. 
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. 

4.2. Define the Physical Group Properties: Fire Boundary Conditions 

 

We will start by applying the thermal boundary conditions (e.g., fire curves). 

 

In GmSAFIR, select Modules -> Geometry -> Physical Groups -> Add -> Curve 

 

    
 

Type the name ‘unexposed’.  

Select the two curves at the top, which are not exposed to the fire. 

The new physical group ‘unexposed’ which we created now contains two elementary entities, 

Lines 9 and 12. 

Type ‘e’.  

The window changes and enables selecting the properties for the ‘unexposed’ group. 

Select ‘frontier constraint’ and ‘F20’. 

Click ‘Add-Update’ to confirm. 

 
 

We can close the window.  

To check, select Modules -> Solver -> SAFIR -> View -> View frontiers 

The frontier ‘F20’ should be displayed on the two top lines. 
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We repeat the procedure to create a second physical group, for the ‘exposed’ curves. 

In GmSAFIR, select Modules -> Geometry -> Physical Groups -> Add -> Curve 

Type the name ‘exposed’.  

Select the curves at the boundary of the section, except Lines 9 and 12 which are not exposed 

to the fire. 

The new physical group ‘exposed’ now contains the relevant elementary entities. 

Type ‘e’.  

The window changes and enables selecting the properties for the ‘unexposed’ group. 

Select ‘frontier constraint’ and ‘ASTME119’. 

Click ‘Add-Update’ to confirm. 

 

  
 

4.3. Define the Physical Group Properties: Materials 

 

We will now define surface physical groups to assign the material properties. 

 

In GmSAFIR, select Modules -> Geometry -> Physical Groups -> Add -> Surface 

 

Type the name ‘steels’.  

Select the steel surface. 

The new physical group ‘steels’ which we created now contains one surface. 

Type ‘e’.  

The window changes and enables selecting the properties for the ‘steels’ group. 

 

Materials are not defined yet. In Property Type, select New Material Definition. 

Material Type: select ‘metal’ 

Material sub-category: select ‘steelec3en’ 

The thermal properties can be left to their default value. 

New material name: type ‘steelm’ 

 

Click ‘add update’. As a result, a new entry appears, ‘Material Names Choice’. The material 

‘steelm’ is now available to be attributed to a physical group. 
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In Property Type, select ‘Surface Material’. 

In Material Name, type ‘steelm’ 

Click ‘Add-Update’. 

This material has now been allocated to the physical group that contains Surface 1. 

This can be checked by selecting Modules -> Solver -> SAFIR -> View -> View materials. 

 
 

We will now define the physical group for the SFRM. 

In GmSAFIR, select Modules -> Geometry -> Physical Groups -> Add -> Surface 

Type the name ‘sfrms’.  

Select the SFRM surface. 

The new physical group ‘sfrms’ which we created now contains one surface. 

Type ‘e’.  

The window changes and enables selecting the properties for the ‘sfrms’ group. 

The material is not defined yet. In Property Type, select New Material Definition. 

Material Type: select ‘insulations’ 

Material sub-category: select ‘insulation’ 

The thermal properties can be input as desired.  

Thermal conductivity: 0.12 W/mK. 

Specific heat: 1200 J/kgK 

Density: 300 kg/m3 

New material name: type ‘sfrmm’ 

Click ‘Add-Update’. 
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The material has been added in the ‘Material Names Choice’. 

  
 

As Property Type, select ‘Surface Material’ 

In Material Name, type ‘sfrmm’ 

Click ‘Add-Update’. 

This material has now been allocated to the physical group that contains Surface 1. 

This can be checked by selecting Modules -> Solver -> SAFIR -> View -> View materials 

 

Another useful visualization is in Tools -> Visibility (or ctrl + shift + v) 

In ‘List’ the physical groups are shown. There are two for surfaces and two for curves. We 

can select the surface ‘sfrms’ and apply to visualize the SFRM only. 

 
 

  



SAFIR® training session  Tutorial – 04/2022 

© Thomas Gernay 2D Thermal steel beam 18 

5. Create the Mesh 

 

In GmSAFIR, select Tools -> Options 

In the window, select Mesh -> General and change the element size factor to 0.2. 

Close the window. 

  
 

Next, select Modules -> Mesh -> 2D 

 

A mesh is automatically generated. 

As this mesh is coarse, select Modules -> Mesh -> Refine by splitting 

We can refine twice. 

We now have a mesh based on triangular elements. 
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Modules -> Mesh -> 2D 

 

(with element size factor 0.2) 

 

Modules -> Mesh -> Refine by splitting 

(x2) 

 
 

 

GmSAFIR offers various options to define and optimize the mesh, which are not covered here. 

For example, the command Modules -> Mesh -> Recombine 2D transforms triangular elements 

into quadrangular elements, but we will not use it here. 
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6. Create SAFIR input file and run the file 

 

In GmSAFIR, select Modules -> Solver -> Create .IN File     (at the bottom of the menu) 

 

The input file ThermalSteel.IN has been generated in the folder. 

 
Run this input file with SAFIR. This can be done by using the command window of the 

executable, or the SAFIR Shell tool. 

 

 
Open the postprocessor DIAMOND to visualize the results. 

 

 
 

DIAMOND can be used to check the geometry, boundary conditions, materials, mesh, etc. as 

well as to plot charts of the temperature at the nodes and draw temperatures on the section. 

  



SAFIR® training session  Tutorial – 04/2022 

© Thomas Gernay 2D Thermal steel beam 21 

7. Creating a configurable GmSAFIR script 

 

GmSAFIR allows reading and modifying the script at each step of the procedure of creating the 

model. 

 

In GmSAFIR, select Modules -> Geometry -> Edit script  to visualize the script in a text editor. 

 

If a mistake is made at any step of the procedure (creation of geometry, physical groups), the 

script can be edited in the text editor. It can then be reloaded using:  

Modules -> Geometry -> Reload script 

and the modification will take effect. 

 

Besides the correction of mistake, another interesting functionality is that the model can be 

made parametric using the script. 

 

In GmSAFIR, select Modules -> Geometry -> Edit script 

We create variables and make the points definition parametric. The original script is on the left. 

The modified one is on the right. Both the ‘Points’ and ‘Translate’ commands now are defined 

as functions of the variables, which are the W12x120 dimensions and the thickness of SFRM. 

 

   
 

After modification, save and close the script. 

Select Modules -> Geometry -> Reload script 

The model does not change. 
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Note that this action (editing the script, reloading the script) has conserved the geometry and 

the physical group definitions. It cannot be applied on the mesh, though. The mesh needs to be 

recreated each time the script is reloaded. 

 

Now, we can change the values of the variables. For example, the thickness of insulation is 

changed from 11 mm to 33 mm. Dimensions of the steel section can also be changed. 

It suffices to change one line in the script, then reload it, and the model is adjusted. 
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For each case: 

- Edit the script, and modify the required input (e.g., depth d of the profile) 

- Reload the script with Modules -> Geometry -> Reload script 

- Recreate the mesh (see Section 5) 

- Create SAFIR input file and run the file (See Section 6) 

 

 


